summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorDoug Hellmann <doug.hellmann@dreamhost.com>2013-08-02 10:39:34 -0400
committerDoug Hellmann <doug.hellmann@dreamhost.com>2013-08-02 10:44:41 -0400
commitc0fe170ca44e3e41b2b6ceb7c6085d3f87b325a8 (patch)
tree07ce446e600a2d290ddc47883aecff84c183ce0d /tox.ini
parent5bab03ee62ee3a4d18baecf7800c49f426e154db (diff)
downloadpycadf-c0fe170ca44e3e41b2b6ceb7c6085d3f87b325a8.tar.gz
initial project setup
Change-Id: I1bbe058cf162549a517814e02a3e8bed70b5dbf8
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini25
1 files changed, 25 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..ab5e71b
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,25 @@
+[tox]
+distribute = False
+envlist = py26,py27,py33,pep8
+
+[testenv]
+setenv = VIRTUAL_ENV={envdir}
+deps = -r{toxinidir}/requirements.txt
+ -r{toxinidir}/test-requirements.txt
+commands = python setup.py testr --slowest --testr-args='{posargs}'
+
+[testenv:pep8]
+commands = flake8
+
+[testenv:cover]
+setenv = VIRTUAL_ENV={envdir}
+commands =
+ python setup.py testr --coverage
+
+[testenv:venv]
+commands = {posargs}
+
+[flake8]
+show-source = True
+exclude = .tox,dist,doc,*.egg,build
+builtins = _