summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.py6
-rw-r--r--test-requirements.txt12
2 files changed, 9 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 8866691..2a0786a 100644
--- a/setup.py
+++ b/setup.py
@@ -14,9 +14,9 @@
# See the License for the specific language governing permissions and
# limitations under the License.
+# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
setuptools.setup(
- setup_requires=['pbr'],
- pbr=True,
-)
+ setup_requires=['pbr>=0.5.21,<1.0'],
+ pbr=True)
diff --git a/test-requirements.txt b/test-requirements.txt
index e4e171b..0a532e2 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -2,21 +2,21 @@
pep8==1.4.5
pyflakes==0.7.2
flake8==2.0
-hacking>=0.5.3,<0.6
+hacking>=0.5.6,<0.8
discover
-fixtures>=0.3.12
+fixtures>=0.3.14
python-subunit
testrepository>=0.0.17
-testscenarios<0.5
-testtools>=0.9.29
+testscenarios>=0.4,<0.5
+testtools>=0.9.32
WebOb>=1.2.3,<1.3
# when we can require tox>= 1.4, this can go into tox.ini:
# [testenv:cover]
# deps = {[testenv]deps} coverage
-coverage
+coverage>=3.6
# this is required for the docs build jobs
-sphinx
+sphinx>=1.1.2
oslo.sphinx