summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--requirements.txt4
-rw-r--r--setup.py1
-rw-r--r--test-requirements.txt10
3 files changed, 7 insertions, 8 deletions
diff --git a/requirements.txt b/requirements.txt
index 6222368..424bcb9 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,7 +1,7 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
-oslo.config>=1.11.0 # Apache-2.0
-oslo.serialization>=1.4.0 # Apache-2.0
+oslo.config>=1.11.0 # Apache-2.0
+oslo.serialization>=1.4.0 # Apache-2.0
pytz>=2013.6
six>=1.9.0
diff --git a/setup.py b/setup.py
index 7363757..056c16c 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,3 @@
-#!/usr/bin/env python
# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
#
# Licensed under the Apache License, Version 2.0 (the "License");
diff --git a/test-requirements.txt b/test-requirements.txt
index 70fa748..971c228 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -2,16 +2,16 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
# Hacking already pins down pep8, pyflakes and flake8
-hacking>=0.10.0,<0.11
+hacking<0.11,>=0.10.0
coverage>=3.6
discover
fixtures>=0.3.14
-oslotest>=1.5.1 # Apache-2.0
+oslotest>=1.5.1 # Apache-2.0
python-subunit>=0.0.18
testrepository>=0.0.18
-testtools>=0.9.36,!=1.2.0
+testtools>=1.4.0
# this is required for the docs build jobs
-oslosphinx>=2.5.0 # Apache-2.0
-sphinx>=1.1.2,!=1.2.0,!=1.3b1,<1.3
+oslosphinx>=2.5.0 # Apache-2.0
+sphinx!=1.2.0,!=1.3b1,<1.3,>=1.1.2