summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Fitzgerald <fitzgen@gmail.com>2010-12-12 17:24:04 -0800
committerNick Fitzgerald <fitzgen@gmail.com>2010-12-12 17:24:04 -0800
commite563e3183c9e6af0c16baecfbe8298f0c0becf8d (patch)
treec7a9102c3e319ecd040bb27799b1542d42b271dc
parente83d03ffefe73c966426a50bc0fe8942fb6f311f (diff)
parent68068e5e691a2bd73832d3f5f51a5728d0f25301 (diff)
downloadpycco-e563e3183c9e6af0c16baecfbe8298f0c0becf8d.tar.gz
Merge branch 'master' of https://github.com/kurige/pycco into kurige-smartypants
-rw-r--r--pycco/main.py9
-rw-r--r--setup.py2
2 files changed, 6 insertions, 5 deletions
diff --git a/pycco/main.py b/pycco/main.py
index 74e31dc..80bc9d1 100644
--- a/pycco/main.py
+++ b/pycco/main.py
@@ -1,12 +1,13 @@
#!/usr/bin/env python
-# **Pycco** is a Python port of [Docco](http://jashkenas.github.com/docco/ ):
+# "**Pycco**" is a Python port of [Docco](http://jashkenas.github.com/docco/ ):
# the original quick-and-dirty, hundred-line-long, literate-programming-style
# documentation generator. It produces HTML that displays your comments
# alongside your code. Comments are passed through
-# [Markdown](http://daringfireball.net/projects/markdown/syntax), and code is
-# passed through [Pygments](http://pygments.org/) syntax highlighting. This
-# page is the result of running Pycco against its own source file.
+# [Markdown](http://daringfireball.net/projects/markdown/syntax) and
+# [SmartyPants](http://daringfireball.net/projects/smartypants), while code is
+# passed through [Pygments](http://pygments.org/) for syntax highlighting.
+# This page is the result of running Pycco against its own source file.
#
# If you install Pycco, you can run it from the command-line:
#
diff --git a/setup.py b/setup.py
index 6686b19..c3bc074 100644
--- a/setup.py
+++ b/setup.py
@@ -15,5 +15,5 @@ setup(
'pycco = pycco.main:main',
]
},
- install_requires = ['markdown', 'pygments', 'pystache'],
+ install_requires = ['markdown', 'pygments', 'pystache', 'smartypants'],
)