summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoreli.bendersky <devnull@localhost>2011-04-29 09:00:43 +0300
committereli.bendersky <devnull@localhost>2011-04-29 09:00:43 +0300
commit84a6a6384df8a3510b022f7302456c56dc7de468 (patch)
tree6f89abc4d6783ec631655b454441d600192a9f76
parent13d6ca8534d4bd65c536eadc647a30432dee2a88 (diff)
downloadpycparser-84a6a6384df8a3510b022f7302456c56dc7de468.tar.gz
changed license notices to BSD in all files
-rw-r--r--README.txt2
-rw-r--r--examples/c-to-c.py2
-rw-r--r--examples/cdecl.py4
-rw-r--r--examples/explore_ast.py4
-rw-r--r--examples/func_calls.py2
-rw-r--r--examples/func_defs.py2
-rw-r--r--examples/using_cpp_libc.py4
-rw-r--r--pycparser/__init__.py2
-rw-r--r--pycparser/_ast_gen.py8
-rw-r--r--pycparser/_build_tables.py4
-rw-r--r--pycparser/c_ast.py4
-rw-r--r--pycparser/c_lexer.py2
-rw-r--r--pycparser/c_parser.py2
-rw-r--r--pycparser/plyparser.py4
-rw-r--r--setup.py2
-rw-r--r--z_test.py24
16 files changed, 32 insertions, 40 deletions
diff --git a/README.txt b/README.txt
index 3e7ae1f..21e10cc 100644
--- a/README.txt
+++ b/README.txt
@@ -48,7 +48,7 @@ What grammar does pycparser follow?
How is pycparser licensed?
--------------------------
-`LGPL <http://www.gnu.org/licenses/lgpl.html>`_
+`New BSD License <http://www.opensource.org/licenses/bsd-license.php>`_
Contact details
---------------
diff --git a/examples/c-to-c.py b/examples/c-to-c.py
index 47f4a16..a292c36 100644
--- a/examples/c-to-c.py
+++ b/examples/c-to-c.py
@@ -8,7 +8,7 @@
# website.
#
# Copyright (C) 2008-2011, Eli Bendersky
-# License: LGPL
+# License: BSD
#-----------------------------------------------------------------
from __future__ import print_function
import sys
diff --git a/examples/cdecl.py b/examples/cdecl.py
index 23148f8..0e07272 100644
--- a/examples/cdecl.py
+++ b/examples/cdecl.py
@@ -17,8 +17,8 @@
# =>
# ar is a pointer to array[10] of pointer to const Node
#
-# Copyright (C) 2008-2010, Eli Bendersky
-# License: LGPL
+# Copyright (C) 2008-2011, Eli Bendersky
+# License: BSD
#-----------------------------------------------------------------
import sys
diff --git a/examples/explore_ast.py b/examples/explore_ast.py
index f845c0f..83f096b 100644
--- a/examples/explore_ast.py
+++ b/examples/explore_ast.py
@@ -9,8 +9,8 @@
# information from the AST.
# It helps to have the _c_ast.yaml file in front of you.
#
-# Copyright (C) 2008-2010, Eli Bendersky
-# License: LGPL
+# Copyright (C) 2008-2011, Eli Bendersky
+# License: BSD
#-----------------------------------------------------------------
import sys
diff --git a/examples/func_calls.py b/examples/func_calls.py
index 4789688..f79d47e 100644
--- a/examples/func_calls.py
+++ b/examples/func_calls.py
@@ -5,7 +5,7 @@
# in a C file.
#
# Copyright (C) 2008-2011, Eli Bendersky
-# License: LGPL
+# License: BSD
#-----------------------------------------------------------------
from __future__ import print_function
import sys
diff --git a/examples/func_defs.py b/examples/func_defs.py
index 1fd1191..9522382 100644
--- a/examples/func_defs.py
+++ b/examples/func_defs.py
@@ -8,7 +8,7 @@
# pycparser.
#
# Copyright (C) 2008-2011, Eli Bendersky
-# License: LGPL
+# License: BSD
#-----------------------------------------------------------------
from __future__ import print_function
import sys
diff --git a/examples/using_cpp_libc.py b/examples/using_cpp_libc.py
index e7c5daa..fa9e6a7 100644
--- a/examples/using_cpp_libc.py
+++ b/examples/using_cpp_libc.py
@@ -5,8 +5,8 @@
# the 'real' cpp if you're on Linux/Unix) and "fake" libc includes
# to parse a file that includes standard C headers.
#
-# Copyright (C) 2008-2009, Eli Bendersky
-# License: LGPL
+# Copyright (C) 2008-2011, Eli Bendersky
+# License: BSD
#-----------------------------------------------------------------
import sys
diff --git a/pycparser/__init__.py b/pycparser/__init__.py
index c86b294..03d3df1 100644
--- a/pycparser/__init__.py
+++ b/pycparser/__init__.py
@@ -5,7 +5,7 @@
# interacting with pycparser
#
# Copyright (C) 2008-2011, Eli Bendersky
-# License: LGPL
+# License: BSD
#-----------------------------------------------------------------
__all__ = ['c_lexer', 'c_parser', 'c_ast']
diff --git a/pycparser/_ast_gen.py b/pycparser/_ast_gen.py
index ab8be9f..8f21284 100644
--- a/pycparser/_ast_gen.py
+++ b/pycparser/_ast_gen.py
@@ -7,8 +7,8 @@
# The design of this module was inspired by astgen.py from the
# Python 2.5 code-base.
#
-# Copyright (C) 2008-2010, Eli Bendersky
-# License: LGPL
+# Copyright (C) 2008-2011, Eli Bendersky
+# License: BSD
#-----------------------------------------------------------------
import pprint
from string import Template
@@ -145,8 +145,8 @@ r'''#-----------------------------------------------------------------
#
# AST Node classes.
#
-# Copyright (C) 2008-2010, Eli Bendersky
-# License: LGPL
+# Copyright (C) 2008-2011, Eli Bendersky
+# License: BSD
#-----------------------------------------------------------------
'''
diff --git a/pycparser/_build_tables.py b/pycparser/_build_tables.py
index 04524e0..a15824e 100644
--- a/pycparser/_build_tables.py
+++ b/pycparser/_build_tables.py
@@ -6,8 +6,8 @@
# Also generates AST code from the configuration file.
# Should be called from the installation directory.
#
-# Copyright (C) 2008-2010, Eli Bendersky
-# License: LGPL
+# Copyright (C) 2008-2011, Eli Bendersky
+# License: BSD
#-----------------------------------------------------------------
# Generate c_ast.py
diff --git a/pycparser/c_ast.py b/pycparser/c_ast.py
index 65fcd5d..9ebdb74 100644
--- a/pycparser/c_ast.py
+++ b/pycparser/c_ast.py
@@ -11,8 +11,8 @@
#
# AST Node classes.
#
-# Copyright (C) 2008-2010, Eli Bendersky
-# License: LGPL
+# Copyright (C) 2008-2011, Eli Bendersky
+# License: BSD
#-----------------------------------------------------------------
diff --git a/pycparser/c_lexer.py b/pycparser/c_lexer.py
index 3517975..90b2730 100644
--- a/pycparser/c_lexer.py
+++ b/pycparser/c_lexer.py
@@ -4,7 +4,7 @@
# CLexer class: lexer for the C language
#
# Copyright (C) 2008-2011, Eli Bendersky
-# License: LGPL
+# License: BSD
#-----------------------------------------------------------------
import re
diff --git a/pycparser/c_parser.py b/pycparser/c_parser.py
index 83c8e19..975b087 100644
--- a/pycparser/c_parser.py
+++ b/pycparser/c_parser.py
@@ -4,7 +4,7 @@
# CParser class: Parser and AST builder for the C language
#
# Copyright (C) 2008-2011, Eli Bendersky
-# License: LGPL
+# License: BSD
#-----------------------------------------------------------------
import re
diff --git a/pycparser/plyparser.py b/pycparser/plyparser.py
index 25bcca3..42d4dc6 100644
--- a/pycparser/plyparser.py
+++ b/pycparser/plyparser.py
@@ -4,8 +4,8 @@
# PLYParser class and other utilites for simplifying programming
# parsers with PLY
#
-# Copyright (C) 2008-2010, Eli Bendersky
-# License: LGPL
+# Copyright (C) 2008-2011, Eli Bendersky
+# License: BSD
#-----------------------------------------------------------------
diff --git a/setup.py b/setup.py
index ae36646..c92a015 100644
--- a/setup.py
+++ b/setup.py
@@ -13,7 +13,7 @@ setup(
C compilers or analysis tools.
""",
install_requires=['ply'],
- license='LGPL',
+ license='BSD',
version='2.03',
author='Eli Bendersky',
maintainer='Eli Bendersky',
diff --git a/z_test.py b/z_test.py
index 205b5cc..de5252b 100644
--- a/z_test.py
+++ b/z_test.py
@@ -76,26 +76,18 @@ class NodeVisitor(object):
if __name__ == "__main__":
source_code = """
- typedef int Node, Hash;
+typedef char FlagType;
- void HashPrint(Hash* hash, void (*PrintFunc)(char*, char*))
- {
- unsigned int i;
+int main()
+{
+}
- if (hash == NULL || hash->heads == NULL)
- return;
+int myproc( int FlagType)
+{
+
+}
- for (i = 0; i < hash->table_size; ++i)
- {
- Node* temp = hash->heads[i];
- while (temp != NULL)
- {
- temp = temp->next;
- PrintFunc(temp->entry->key, temp->entry->value);
- }
- }
- }
"""
#--------------- Lexing