summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoreli.bendersky <devnull@localhost>2011-10-16 06:21:59 +0200
committereli.bendersky <devnull@localhost>2011-10-16 06:21:59 +0200
commite91008a9ac0fc4b4870335b15172621d22833092 (patch)
tree34f8b1fc06a7fc623da878a9cdc4d51b6c407a3f
parent460ed4d1c990105bf17760e309aa71e9d2e27c28 (diff)
downloadpycparser-e91008a9ac0fc4b4870335b15172621d22833092.tar.gz
Preparing for release 2.05
-rw-r--r--README.html118
-rw-r--r--README.txt17
-rw-r--r--pycparser/__init__.py2
-rw-r--r--setup.py6
-rw-r--r--z_test.py26
5 files changed, 100 insertions, 69 deletions
diff --git a/README.html b/README.html
index fbf5617..f0c9fad 100644
--- a/README.html
+++ b/README.html
@@ -3,14 +3,14 @@
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
-<meta name="generator" content="Docutils 0.6: http://docutils.sourceforge.net/" />
-<title>pycparser v2.04</title>
+<meta name="generator" content="Docutils 0.9: http://docutils.sourceforge.net/" />
+<title>pycparser v2.05</title>
<meta name="author" content="Eli Bendersky" />
<style type="text/css">
/*
:Author: David Goodger (goodger@python.org)
-:Id: $Id: html4css1.css 5951 2009-05-18 18:03:10Z milde $
+:Id: $Id: html4css1.css 7056 2011-06-17 10:50:48Z milde $
:Copyright: This stylesheet has been placed in the public domain.
Default cascading style sheet for the HTML output of Docutils.
@@ -48,6 +48,10 @@ blockquote.epigraph {
dl.docutils dd {
margin-bottom: 0.5em }
+object[type="image/svg+xml"], object[type="application/x-shockwave-flash"] {
+ overflow: hidden;
+}
+
/* Uncomment (and remove this text!) to get bold-faced definition list terms
dl.docutils dt {
font-weight: bold }
@@ -158,16 +162,22 @@ h2.subtitle {
hr.docutils {
width: 75% }
-img.align-left, .figure.align-left{
+img.align-left, .figure.align-left, object.align-left {
clear: left ;
float: left ;
margin-right: 1em }
-img.align-right, .figure.align-right {
+img.align-right, .figure.align-right, object.align-right {
clear: right ;
float: right ;
margin-left: 1em }
+img.align-center, .figure.align-center, object.align-center {
+ display: block;
+ margin-left: auto;
+ margin-right: auto;
+}
+
.align-left {
text-align: left }
@@ -180,7 +190,7 @@ img.align-right, .figure.align-right {
/* reset inner alignment in figures */
div.align-right {
- text-align: left }
+ text-align: inherit }
/* div.align-center * { */
/* text-align: left } */
@@ -240,7 +250,7 @@ pre.address {
margin-top: 0 ;
font: inherit }
-pre.literal-block, pre.doctest-block {
+pre.literal-block, pre.doctest-block, pre.math {
margin-left: 2em ;
margin-right: 2em }
@@ -305,8 +315,8 @@ ul.auto-toc {
</style>
</head>
<body>
-<div class="document" id="pycparser-v2-04">
-<h1 class="title">pycparser v2.04</h1>
+<div class="document" id="pycparser-v2-05">
+<h1 class="title">pycparser v2.05</h1>
<table class="docinfo" frame="void" rules="none">
<col class="docinfo-name" />
<col class="docinfo-content" />
@@ -350,11 +360,11 @@ ul.auto-toc {
<h1>1&nbsp;&nbsp;&nbsp;Introduction</h1>
<div class="section" id="what-is-pycparser">
<h2>1.1&nbsp;&nbsp;&nbsp;What is pycparser?</h2>
-<p><tt class="docutils literal"><span class="pre">pycparser</span></tt> is a parser for the C language, written in pure Python. It is a module designed to be easily integrated into applications that need to parse C source code.</p>
+<p><tt class="docutils literal">pycparser</tt> is a parser for the C language, written in pure Python. It is a module designed to be easily integrated into applications that need to parse C source code.</p>
</div>
<div class="section" id="what-is-it-good-for">
<h2>1.2&nbsp;&nbsp;&nbsp;What is it good for?</h2>
-<p>Anything that needs C code to be parsed. The following are some uses for <tt class="docutils literal"><span class="pre">pycparser</span></tt>, taken from real user reports:</p>
+<p>Anything that needs C code to be parsed. The following are some uses for <tt class="docutils literal">pycparser</tt>, taken from real user reports:</p>
<ul class="simple">
<li>C code obfuscator</li>
<li>Front-end for various specialized C compilers</li>
@@ -362,16 +372,16 @@ ul.auto-toc {
<li>Automatic unit-test discovery</li>
<li>Adding specialized extensions to the C language</li>
</ul>
-<p><tt class="docutils literal"><span class="pre">pycparser</span></tt> is unique in the sense that it's written in pure Python - a very high level language that's easy to experiment with and tweak. To people familiar with Lex and Yacc, <tt class="docutils literal"><span class="pre">pycparser</span></tt>'s code will be simple to understand.</p>
+<p><tt class="docutils literal">pycparser</tt> is unique in the sense that it's written in pure Python - a very high level language that's easy to experiment with and tweak. To people familiar with Lex and Yacc, <tt class="docutils literal">pycparser</tt>'s code will be simple to understand.</p>
</div>
<div class="section" id="which-version-of-c-does-pycparser-support">
<h2>1.3&nbsp;&nbsp;&nbsp;Which version of C does pycparser support?</h2>
-<p><tt class="docutils literal"><span class="pre">pycparser</span></tt> aims to support the full C99 language (according to the standard ISO/IEC 9899). This is a new feature in the version 2.x series - earlier versions only supported C89. For more information on the change, read <a class="reference external" href="http://code.google.com/p/pycparser/wiki/C99support">this wiki page</a>.</p>
-<p><tt class="docutils literal"><span class="pre">pycparser</span></tt> doesn't support any GCC extensions.</p>
+<p><tt class="docutils literal">pycparser</tt> aims to support the full C99 language (according to the standard ISO/IEC 9899). This is a new feature in the version 2.x series - earlier versions only supported C89. For more information on the change, read <a class="reference external" href="http://code.google.com/p/pycparser/wiki/C99support">this wiki page</a>.</p>
+<p><tt class="docutils literal">pycparser</tt> doesn't support any GCC extensions.</p>
</div>
<div class="section" id="what-grammar-does-pycparser-follow">
<h2>1.4&nbsp;&nbsp;&nbsp;What grammar does pycparser follow?</h2>
-<p><tt class="docutils literal"><span class="pre">pycparser</span></tt> very closely follows the C grammar provided in the end of the C99 standard document</p>
+<p><tt class="docutils literal">pycparser</tt> very closely follows the C grammar provided in the end of the C99 standard document</p>
</div>
<div class="section" id="how-is-pycparser-licensed">
<h2>1.5&nbsp;&nbsp;&nbsp;How is pycparser licensed?</h2>
@@ -379,7 +389,7 @@ ul.auto-toc {
</div>
<div class="section" id="contact-details">
<h2>1.6&nbsp;&nbsp;&nbsp;Contact details</h2>
-<p>Drop me an email to <a class="reference external" href="mailto:eliben&#64;gmail.com">eliben&#64;gmail.com</a> for any questions regarding <tt class="docutils literal"><span class="pre">pycparser</span></tt>. For reporting problems with <tt class="docutils literal"><span class="pre">pycparser</span></tt> or submitting feature requests, the best way is to open an issue on the <a class="reference external" href="http://code.google.com/p/pycparser/">pycparser page at Google Code</a>.</p>
+<p>Drop me an email to <a class="reference external" href="mailto:eliben&#64;gmail.com">eliben&#64;gmail.com</a> for any questions regarding <tt class="docutils literal">pycparser</tt>. For reporting problems with <tt class="docutils literal">pycparser</tt> or submitting feature requests, the best way is to open an issue on the <a class="reference external" href="http://code.google.com/p/pycparser/">pycparser page at Google Code</a>.</p>
</div>
</div>
<div class="section" id="installing">
@@ -387,19 +397,23 @@ ul.auto-toc {
<div class="section" id="prerequisites">
<h2>2.1&nbsp;&nbsp;&nbsp;Prerequisites</h2>
<ul class="simple">
-<li><tt class="docutils literal"><span class="pre">pycparser</span></tt> was tested on Python 2.6 and 3.2, on both Linux and Windows. It should work on any later version (in both the 2.x and 3.x lines) as well.</li>
-<li><tt class="docutils literal"><span class="pre">pycparser</span></tt> uses the PLY module for the actual lexer and parser construction. Install PLY from <a class="reference external" href="http://www.dabeaz.com/ply/">its website</a>.</li>
+<li><tt class="docutils literal">pycparser</tt> was tested on Python 2.6 and 3.2, on both Linux and Windows. It should work on any later version (in both the 2.x and 3.x lines) as well.</li>
+<li><tt class="docutils literal">pycparser</tt> uses the PLY module for the actual lexer and parser construction. Install PLY from <a class="reference external" href="http://www.dabeaz.com/ply/">its website</a>.</li>
</ul>
</div>
<div class="section" id="installation-process">
<h2>2.2&nbsp;&nbsp;&nbsp;Installation process</h2>
-<p>Installing <tt class="docutils literal"><span class="pre">pycparser</span></tt> is very simple. Once you download it from its <a class="reference external" href="http://code.google.com/p/pycparser/">website</a> and unzip the package, you just have to execute the standard <tt class="docutils literal"><span class="pre">python</span> <span class="pre">setup.py</span> <span class="pre">install</span></tt>. The setup script will then place the <tt class="docutils literal"><span class="pre">pycparser</span></tt> module into <tt class="docutils literal"><span class="pre">site-packages</span></tt> in your Python's installation library.</p>
-<p>It's recommended to run <tt class="docutils literal"><span class="pre">_build_tables.py</span></tt> in the <tt class="docutils literal"><span class="pre">pycparser</span></tt> code directory after installation to make sure the parsing tables of PLY are pre-generated. This can make your code run faster.</p>
+<p>Installing <tt class="docutils literal">pycparser</tt> is very simple. Once you download it from its <a class="reference external" href="http://code.google.com/p/pycparser/">website</a> and unzip the package, you just have to execute the standard <tt class="docutils literal">python setup.py install</tt>. The setup script will then place the <tt class="docutils literal">pycparser</tt> module into <tt class="docutils literal"><span class="pre">site-packages</span></tt> in your Python's installation library.</p>
+<p>Alternatively, since <tt class="docutils literal">pycparser</tt> is listed in the <a class="reference external" href="http://pypi.python.org/pypi/pycparser">Python Package Index</a> (PyPI), you can install it using your favorite Python packaging/distribution tool, for example with:</p>
+<pre class="literal-block">
+&gt; pip install pycparser
+</pre>
+<p>It's recommended to run <tt class="docutils literal">_build_tables.py</tt> in the <tt class="docutils literal">pycparser</tt> code directory after installation to make sure the parsing tables of PLY are pre-generated. This can make your code run faster.</p>
</div>
<div class="section" id="known-problems">
<h2>2.3&nbsp;&nbsp;&nbsp;Known problems</h2>
<ul class="simple">
-<li>Some users who've installed a new version of <tt class="docutils literal"><span class="pre">pycparser</span></tt> over an existing version ran into a problem using the newly installed library. This has to do with parse tables staying around as <tt class="docutils literal"><span class="pre">.pyc</span></tt> files from the older version. If you see unexplained errors from <tt class="docutils literal"><span class="pre">pycparser</span></tt> after an upgrade, remove it (by deleting the <tt class="docutils literal"><span class="pre">pycparser</span></tt> directory in your Python's <tt class="docutils literal"><span class="pre">site-packages</span></tt>, or wherever you installed it) and install again.</li>
+<li>Some users who've installed a new version of <tt class="docutils literal">pycparser</tt> over an existing version ran into a problem using the newly installed library. This has to do with parse tables staying around as <tt class="docutils literal">.pyc</tt> files from the older version. If you see unexplained errors from <tt class="docutils literal">pycparser</tt> after an upgrade, remove it (by deleting the <tt class="docutils literal">pycparser</tt> directory in your Python's <tt class="docutils literal"><span class="pre">site-packages</span></tt>, or wherever you installed it) and install again.</li>
</ul>
</div>
</div>
@@ -407,45 +421,45 @@ ul.auto-toc {
<h1>3&nbsp;&nbsp;&nbsp;Using</h1>
<div class="section" id="interaction-with-the-c-preprocessor">
<h2>3.1&nbsp;&nbsp;&nbsp;Interaction with the C preprocessor</h2>
-<p>In order to be compilable, C code must be preprocessed by the C preprocessor - <tt class="docutils literal"><span class="pre">cpp</span></tt>. <tt class="docutils literal"><span class="pre">cpp</span></tt> handles preprocessing directives like <tt class="docutils literal"><span class="pre">#include</span></tt> and <tt class="docutils literal"><span class="pre">#define</span></tt>, removes comments, and does other minor tasks that prepare the C code for compilation.</p>
-<p>For all but the most trivial snippets of C code, <tt class="docutils literal"><span class="pre">pycparser</span></tt>, like a C compiler, must receive preprocessed C code in order to function correctly. If you import the top-level <tt class="docutils literal"><span class="pre">parse_file</span></tt> function from the <tt class="docutils literal"><span class="pre">pycparser</span></tt> package, it will interact with <tt class="docutils literal"><span class="pre">cpp</span></tt> for you, as long as it's in your PATH, or you provide a path to it.</p>
-<p>On the vast majority of Linux systems, <tt class="docutils literal"><span class="pre">cpp</span></tt> is installed and is in the PATH. If you're on Windows and don't have <tt class="docutils literal"><span class="pre">cpp</span></tt> somewhere, you can use the one provided in the <tt class="docutils literal"><span class="pre">utils</span></tt> directory in <tt class="docutils literal"><span class="pre">pycparser</span></tt>'s distribution. This <tt class="docutils literal"><span class="pre">cpp</span></tt> executable was compiled from the <a class="reference external" href="http://www.cs.princeton.edu/software/lcc/">LCC distribution</a>, and is provided under LCC's license terms.</p>
+<p>In order to be compilable, C code must be preprocessed by the C preprocessor - <tt class="docutils literal">cpp</tt>. <tt class="docutils literal">cpp</tt> handles preprocessing directives like <tt class="docutils literal">#include</tt> and <tt class="docutils literal">#define</tt>, removes comments, and does other minor tasks that prepare the C code for compilation.</p>
+<p>For all but the most trivial snippets of C code, <tt class="docutils literal">pycparser</tt>, like a C compiler, must receive preprocessed C code in order to function correctly. If you import the top-level <tt class="docutils literal">parse_file</tt> function from the <tt class="docutils literal">pycparser</tt> package, it will interact with <tt class="docutils literal">cpp</tt> for you, as long as it's in your PATH, or you provide a path to it.</p>
+<p>On the vast majority of Linux systems, <tt class="docutils literal">cpp</tt> is installed and is in the PATH. If you're on Windows and don't have <tt class="docutils literal">cpp</tt> somewhere, you can use the one provided in the <tt class="docutils literal">utils</tt> directory in <tt class="docutils literal">pycparser</tt>'s distribution. This <tt class="docutils literal">cpp</tt> executable was compiled from the <a class="reference external" href="http://www.cs.princeton.edu/software/lcc/">LCC distribution</a>, and is provided under LCC's license terms.</p>
</div>
<div class="section" id="what-about-the-standard-c-library-headers">
<h2>3.2&nbsp;&nbsp;&nbsp;What about the standard C library headers?</h2>
-<p>C code almost always includes various header files from the standard C library, like <tt class="docutils literal"><span class="pre">stdio.h</span></tt>. While, with some effort, <tt class="docutils literal"><span class="pre">pycparser</span></tt> can be made to parse the standard headers from any C compiler, it's much simpler to use the provided &quot;fake&quot; standard includes in <tt class="docutils literal"><span class="pre">utils/fake_libc_include</span></tt>. These are standard C header files that contain only the bare necessities to allow valid parsing of the files that use them. As a bonus, since they're minimal, it can significantly improve the performance of parsing C files.</p>
-<p>See the <tt class="docutils literal"><span class="pre">using_cpp_libc.py</span></tt> example for more details.</p>
+<p>C code almost always includes various header files from the standard C library, like <tt class="docutils literal">stdio.h</tt>. While, with some effort, <tt class="docutils literal">pycparser</tt> can be made to parse the standard headers from any C compiler, it's much simpler to use the provided &quot;fake&quot; standard includes in <tt class="docutils literal">utils/fake_libc_include</tt>. These are standard C header files that contain only the bare necessities to allow valid parsing of the files that use them. As a bonus, since they're minimal, it can significantly improve the performance of parsing C files.</p>
+<p>See the <tt class="docutils literal">using_cpp_libc.py</tt> example for more details.</p>
</div>
<div class="section" id="basic-usage">
<h2>3.3&nbsp;&nbsp;&nbsp;Basic usage</h2>
-<p>Take a look at the <tt class="docutils literal"><span class="pre">examples</span></tt> directory of the distribution for a few examples of using <tt class="docutils literal"><span class="pre">pycparser</span></tt>. These should be enough to get you started.</p>
+<p>Take a look at the <tt class="docutils literal">examples</tt> directory of the distribution for a few examples of using <tt class="docutils literal">pycparser</tt>. These should be enough to get you started.</p>
</div>
<div class="section" id="advanced-usage">
<h2>3.4&nbsp;&nbsp;&nbsp;Advanced usage</h2>
-<p>The public interface of <tt class="docutils literal"><span class="pre">pycparser</span></tt> is well documented with comments in <tt class="docutils literal"><span class="pre">pycparser/c_parser.py</span></tt>. For a detailed overview of the various AST nodes created by the parser, see <tt class="docutils literal"><span class="pre">pycparser/_c_ast.cfg</span></tt>.</p>
+<p>The public interface of <tt class="docutils literal">pycparser</tt> is well documented with comments in <tt class="docutils literal">pycparser/c_parser.py</tt>. For a detailed overview of the various AST nodes created by the parser, see <tt class="docutils literal">pycparser/_c_ast.cfg</tt>.</p>
<p>There's also a <a class="reference external" href="http://code.google.com/p/pycparser/wiki/FAQ">FAQ available here</a>. In any case, you can always drop me an <a class="reference external" href="mailto:eliben&#64;gmail.com">email</a> for help.</p>
</div>
</div>
<div class="section" id="modifying">
<h1>4&nbsp;&nbsp;&nbsp;Modifying</h1>
-<p>There are a few points to keep in mind when modifying <tt class="docutils literal"><span class="pre">pycparser</span></tt>:</p>
+<p>There are a few points to keep in mind when modifying <tt class="docutils literal">pycparser</tt>:</p>
<ul class="simple">
-<li>The code for <tt class="docutils literal"><span class="pre">pycparser</span></tt>'s AST nodes is automatically generated from a configuration file - <tt class="docutils literal"><span class="pre">_c_ast.cfg</span></tt>, by <tt class="docutils literal"><span class="pre">_ast_gen.py</span></tt>. If you modify the AST configuration, make sure to re-generate the code.</li>
-<li>Make sure you understand the optimized mode of <tt class="docutils literal"><span class="pre">pycparser</span></tt> - for that you must read the docstring in the constructor of the <tt class="docutils literal"><span class="pre">CParser</span></tt> class. For development you should create the parser without optimizations, so that it will regenerate the Yacc and Lex tables when you change the grammar.</li>
+<li>The code for <tt class="docutils literal">pycparser</tt>'s AST nodes is automatically generated from a configuration file - <tt class="docutils literal">_c_ast.cfg</tt>, by <tt class="docutils literal">_ast_gen.py</tt>. If you modify the AST configuration, make sure to re-generate the code.</li>
+<li>Make sure you understand the optimized mode of <tt class="docutils literal">pycparser</tt> - for that you must read the docstring in the constructor of the <tt class="docutils literal">CParser</tt> class. For development you should create the parser without optimizations, so that it will regenerate the Yacc and Lex tables when you change the grammar.</li>
</ul>
</div>
<div class="section" id="package-contents">
<h1>5&nbsp;&nbsp;&nbsp;Package contents</h1>
-<p>Once you unzip the <tt class="docutils literal"><span class="pre">pycparser</span></tt> package, you'll see the following files and directories:</p>
+<p>Once you unzip the <tt class="docutils literal">pycparser</tt> package, you'll see the following files and directories:</p>
<dl class="docutils">
<dt>README.txt/html:</dt>
<dd>This README file.</dd>
<dt>setup.py:</dt>
<dd>Installation script</dd>
<dt>examples/:</dt>
-<dd>A directory with some examples of using <tt class="docutils literal"><span class="pre">pycparser</span></tt></dd>
+<dd>A directory with some examples of using <tt class="docutils literal">pycparser</tt></dd>
<dt>pycparser/:</dt>
-<dd>The <tt class="docutils literal"><span class="pre">pycparser</span></tt> module source code.</dd>
+<dd>The <tt class="docutils literal">pycparser</tt> module source code.</dd>
<dt>tests/:</dt>
<dd>Unit tests.</dd>
<dt>utils/cpp.exe:</dt>
@@ -458,11 +472,23 @@ ul.auto-toc {
</div>
<div class="section" id="contributors">
<h1>6&nbsp;&nbsp;&nbsp;Contributors</h1>
-<p>Some people have contributed to <tt class="docutils literal"><span class="pre">pycparser</span></tt> by opening issues on bugs they've found and/or submitting patches. The list of contributors is at <a class="reference external" href="http://code.google.com/p/pycparser/wiki/Contributors">this pycparser Wiki page</a>.</p>
+<p>Some people have contributed to <tt class="docutils literal">pycparser</tt> by opening issues on bugs they've found and/or submitting patches. The list of contributors is at <a class="reference external" href="http://code.google.com/p/pycparser/wiki/Contributors">this pycparser Wiki page</a>.</p>
</div>
<div class="section" id="changelog">
<h1>7&nbsp;&nbsp;&nbsp;Changelog</h1>
<ul class="simple">
+<li>Version 2.05 (16.10.2011)<ul>
+<li>Added support for the C99 <tt class="docutils literal">_Bool</tt> type and <tt class="docutils literal">stdbool.h</tt> header file</li>
+<li>Expanded <tt class="docutils literal">examples/explore_ast.py</tt> with more details on working with the
+AST</li>
+<li>Relaxed the rules on parsing unnamed struct members (helps parse <tt class="docutils literal">windows.h</tt>)</li>
+<li>Bug fixes:<ul>
+<li>Fixed spacing issue for some type declarations</li>
+<li>Issue 47: display empty statements (lone ';') correctly after parsing</li>
+</ul>
+</li>
+</ul>
+</li>
<li>Version 2.04 (21.05.2011)<ul>
<li>License changed from LGPL to BSD</li>
<li>Bug fixes:<ul>
@@ -482,14 +508,14 @@ ul.auto-toc {
<li>Issue 23: fix coordinates of Cast nodes</li>
</ul>
</li>
-<li>New example added (<tt class="docutils literal"><span class="pre">examples/c-to-c.py</span></tt>) for translating ASTs generated by <tt class="docutils literal"><span class="pre">pycparser</span></tt> back into C code.</li>
-<li><tt class="docutils literal"><span class="pre">pycparser</span></tt> is now on PyPI (Python Package Index)</li>
-<li>Created <a class="reference external" href="http://code.google.com/p/pycparser/wiki/FAQ">FAQ</a> on the <tt class="docutils literal"><span class="pre">pycparser</span></tt> project page</li>
-<li>Removed support for Python 2.5. <tt class="docutils literal"><span class="pre">pycparser</span></tt> supports Python 2 from 2.6 and on, and Python 3.</li>
+<li>New example added (<tt class="docutils literal"><span class="pre">examples/c-to-c.py</span></tt>) for translating ASTs generated by <tt class="docutils literal">pycparser</tt> back into C code.</li>
+<li><tt class="docutils literal">pycparser</tt> is now on PyPI (Python Package Index)</li>
+<li>Created <a class="reference external" href="http://code.google.com/p/pycparser/wiki/FAQ">FAQ</a> on the <tt class="docutils literal">pycparser</tt> project page</li>
+<li>Removed support for Python 2.5. <tt class="docutils literal">pycparser</tt> supports Python 2 from 2.6 and on, and Python 3.</li>
</ul>
</li>
<li>Version 2.02 (10.12.2010)<ul>
-<li>The name of a <tt class="docutils literal"><span class="pre">NamedInitializer</span></tt> node was turned into a sequence of nodes
+<li>The name of a <tt class="docutils literal">NamedInitializer</tt> node was turned into a sequence of nodes
instead of an attribute, to make it discoverable by the AST node visitor.</li>
<li>Documentation updates</li>
</ul>
@@ -505,7 +531,7 @@ instead of an attribute, to make it discoverable by the AST node visitor.</li>
</li>
<li>Version 1.08 (09.10.2010)<ul>
<li>Bug fixes:<ul>
-<li>Correct handling of <tt class="docutils literal"><span class="pre">do{}</span> <span class="pre">...</span> <span class="pre">while</span></tt> statements in some cases</li>
+<li>Correct handling of <tt class="docutils literal">do{} ... while</tt> statements in some cases</li>
<li>Issues 6 &amp; 7: Concatenation of string literals</li>
<li>Issue 9: Support for unnamed bitfields in structs</li>
</ul>
@@ -513,7 +539,7 @@ instead of an attribute, to make it discoverable by the AST node visitor.</li>
</ul>
</li>
<li>Version 1.07 (18.05.2010)<ul>
-<li>Python 3.1 compatibility: <tt class="docutils literal"><span class="pre">pycparser</span></tt> was modified to run on Python 3.1 as well as 2.6</li>
+<li>Python 3.1 compatibility: <tt class="docutils literal">pycparser</tt> was modified to run on Python 3.1 as well as 2.6</li>
</ul>
</li>
<li>Version 1.06 (10.04.2010)<ul>
@@ -523,15 +549,15 @@ instead of an attribute, to make it discoverable by the AST node visitor.</li>
<li>parsing failed on some abstract declarator rules</li>
</ul>
</li>
-<li>Linux compatibility: fixed end-of-line and <tt class="docutils literal"><span class="pre">cpp</span></tt> path issues to allow all tests and examples run on Linux</li>
+<li>Linux compatibility: fixed end-of-line and <tt class="docutils literal">cpp</tt> path issues to allow all tests and examples run on Linux</li>
</ul>
</li>
<li>Version 1.05 (16.10.2009)<ul>
-<li>Fixed the <tt class="docutils literal"><span class="pre">parse_file</span></tt> auxiliary function to handle multiple arguments to <tt class="docutils literal"><span class="pre">cpp</span></tt> correctly</li>
+<li>Fixed the <tt class="docutils literal">parse_file</tt> auxiliary function to handle multiple arguments to <tt class="docutils literal">cpp</tt> correctly</li>
</ul>
</li>
<li>Version 1.04 (22.05.2009)<ul>
-<li>Added the <tt class="docutils literal"><span class="pre">fake_libc_include</span></tt> directory to allow parsing of C code that uses standard C library include files without dependency on a real C library.</li>
+<li>Added the <tt class="docutils literal">fake_libc_include</tt> directory to allow parsing of C code that uses standard C library include files without dependency on a real C library.</li>
<li>Tested with Python 2.6 and PLY 3.2</li>
</ul>
</li>
@@ -540,7 +566,7 @@ instead of an attribute, to make it discoverable by the AST node visitor.</li>
</ul>
</li>
<li>Version 1.02 (16.01.2009)<ul>
-<li>Fixed problem of parsing struct/enum/union names that were named similarly to previously defined <tt class="docutils literal"><span class="pre">typedef</span></tt> types.</li>
+<li>Fixed problem of parsing struct/enum/union names that were named similarly to previously defined <tt class="docutils literal">typedef</tt> types.</li>
</ul>
</li>
<li>Version 1.01 (09.01.2009)<ul>
diff --git a/README.txt b/README.txt
index e36668b..49f1063 100644
--- a/README.txt
+++ b/README.txt
@@ -1,5 +1,5 @@
===============
-pycparser v2.04
+pycparser v2.05
===============
:Author: `Eli Bendersky <http://eli.thegreenplace.net>`_
@@ -70,6 +70,10 @@ Installation process
Installing ``pycparser`` is very simple. Once you download it from its `website <http://code.google.com/p/pycparser/>`_ and unzip the package, you just have to execute the standard ``python setup.py install``. The setup script will then place the ``pycparser`` module into ``site-packages`` in your Python's installation library.
+Alternatively, since ``pycparser`` is listed in the `Python Package Index <http://pypi.python.org/pypi/pycparser>`_ (PyPI), you can install it using your favorite Python packaging/distribution tool, for example with::
+
+ > pip install pycparser
+
It's recommended to run ``_build_tables.py`` in the ``pycparser`` code directory after installation to make sure the parsing tables of PLY are pre-generated. This can make your code run faster.
Known problems
@@ -154,6 +158,17 @@ Some people have contributed to ``pycparser`` by opening issues on bugs they've
Changelog
=========
++ Version 2.05 (16.10.2011)
+
+ - Added support for the C99 ``_Bool`` type and ``stdbool.h`` header file
+ - Expanded ``examples/explore_ast.py`` with more details on working with the
+ AST
+ - Relaxed the rules on parsing unnamed struct members (helps parse ``windows.h``)
+ - Bug fixes:
+
+ * Fixed spacing issue for some type declarations
+ * Issue 47: display empty statements (lone ';') correctly after parsing
+
+ Version 2.04 (21.05.2011)
- License changed from LGPL to BSD
diff --git a/pycparser/__init__.py b/pycparser/__init__.py
index b89de53..377048b 100644
--- a/pycparser/__init__.py
+++ b/pycparser/__init__.py
@@ -9,7 +9,7 @@
#-----------------------------------------------------------------
__all__ = ['c_lexer', 'c_parser', 'c_ast']
-__version__ = '2.04'
+__version__ = '2.05'
from subprocess import Popen, PIPE
diff --git a/setup.py b/setup.py
index 5c2dbcb..b477e8d 100644
--- a/setup.py
+++ b/setup.py
@@ -14,13 +14,15 @@ setup(
""",
install_requires=['ply'],
license='BSD',
- version='2.04',
+ version='2.05',
author='Eli Bendersky',
maintainer='Eli Bendersky',
author_email='eliben@gmail.com',
url='http://code.google.com/p/pycparser/',
platforms='Cross Platform',
-
+ classifiers = [
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 3',],
packages=['pycparser'],
package_data={'pycparser': ['*.cfg']},
)
diff --git a/z_test.py b/z_test.py
index dd8c5b0..1d3d226 100644
--- a/z_test.py
+++ b/z_test.py
@@ -75,26 +75,14 @@ class NodeVisitor(object):
if __name__ == "__main__":
- source_code = """
- typedef long int POINT;
- typedef int HWND;
- typedef int UINT;
- typedef int ULONG_PTR;
- typedef int DWORD;
-struct _MIDL_STUB_MESSAGE MIDL_STUB_MESSAGE,*PMIDL_STUB_MESSAGE;
-typedef struct tagMOUSEHOOKSTRUCT {
- POINT pt;
- HWND hwnd;
- UINT wHitTestCode;
- ULONG_PTR dwExtraInfo;
-} MOUSEHOOKSTRUCT, *LPMOUSEHOOKSTRUCT, *PMOUSEHOOKSTRUCT;
+ source_code = '''
+ static void foo(int k)
+ {
+ j = p && r || q;
+ return j;
+ }
+'''
-typedef struct tagMOUSEHOOKSTRUCTEX
-{
- MOUSEHOOKSTRUCT;
- DWORD mouseData;
-} MOUSEHOOKSTRUCTEX, *LPMOUSEHOOKSTRUCTEX, *PMOUSEHOOKSTRUCTEX;
-"""
#--------------- Lexing
#~ def errfoo(msg, a, b):