summaryrefslogtreecommitdiff
path: root/TODO.txt
diff options
context:
space:
mode:
authoreli.bendersky <devnull@localhost>2010-10-29 12:02:32 +0200
committereli.bendersky <devnull@localhost>2010-10-29 12:02:32 +0200
commit145890da7bc84269e23aa73b4fce2ddd9e263b4f (patch)
treed16121ce756399111976cc1654872569e0ae2a92 /TODO.txt
parentd465fa4a8e9e2df8a08e7f7744f66f876d5e46ba (diff)
downloadpycparser-145890da7bc84269e23aa73b4fce2ddd9e263b4f.tar.gz
Implemented declarations in first expr of a For loop, for C99
Diffstat (limited to 'TODO.txt')
-rw-r--r--TODO.txt22
1 files changed, 18 insertions, 4 deletions
diff --git a/TODO.txt b/TODO.txt
index a5c10c7..c485264 100644
--- a/TODO.txt
+++ b/TODO.txt
@@ -1,3 +1,17 @@
+Todo
+----
+
+Pycparser 2: the idea is to "mostly" support C99
+
+Implement:
+
+- new keywords restrict, inline
+- mix declarations and statements inside a block
+- VLAs (non-constants in arr[n]), including [*] for parameter lists
+- declarations in the first expression of "for" loops
+- named initializers for structs and arrays
+
+
Fixes since last:
------------------
@@ -9,14 +23,14 @@ Version Update
setup.py, __init__.py, README.txt
+Build docs and distribution
+---------------------------
rst2html readme.txt > readme.html
-
setup.py sdist
-
-
-
+Misc
+----
yacc optimization:
- If parsetab.py/pyc doesn't exist in the path, the table will be reconstructed anyway, regardless of the optimize parameter