summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEli Bendersky <eliben@gmail.com>2013-12-28 08:53:43 -0800
committerEli Bendersky <eliben@gmail.com>2013-12-28 08:53:43 -0800
commit62a4d2a19aace9e0b99283c2edcac2a139fd73ac (patch)
treef34590d652b09041a92a6311d0918ebd79bc6ea8 /setup.py
parent6210c0224d4b83886c890684d9cd49de234025c0 (diff)
downloadpycparser-62a4d2a19aace9e0b99283c2edcac2a139fd73ac.tar.gz
Revert "Run post install task executing _build_tables"
This reverts commit 441d5447e485388367fc08c94e5e35e9e2ac1ddc.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 0 insertions, 23 deletions
diff --git a/setup.py b/setup.py
index cb68cd7..0801f6f 100644
--- a/setup.py
+++ b/setup.py
@@ -1,27 +1,5 @@
import os, sys
from distutils.core import setup
-from distutils.command.install import install as _install
-from distutils.command.sdist import sdist as _sdist
-
-
-def _run_build_tables(dir):
- from subprocess import call
- call([sys.executable, '_build_tables.py'],
- cwd=os.path.join(dir, 'pycparser'))
-
-
-class install(_install):
- def run(self):
- _install.run(self)
- self.execute(_run_build_tables, (self.install_lib,),
- msg="Build the lexing/parsing tables")
-
-
-class sdist(_sdist):
- def make_release_tree(self, basedir, files):
- _sdist.make_release_tree(self, basedir, files)
- self.execute(_run_build_tables, (basedir,),
- msg="Build the lexing/parsing tables")
setup(
@@ -46,7 +24,6 @@ setup(
'Programming Language :: Python :: 3',],
packages=['pycparser', 'pycparser.ply'],
package_data={'pycparser': ['*.cfg']},
- cmdclass={'install': install, 'sdist': sdist},
)