summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-06-28 06:12:24 -0700
committerEli Bendersky <eliben@users.noreply.github.com>2018-06-28 06:12:24 -0700
commita301cbbd55cd3e73c5476f3c1cc3e355dcf30ff0 (patch)
tree9f4b8c52c476142e814adaf00d113d501a61fb88 /setup.py
parent0baa8f452c23d006ef01e593afc90a5caf1da0a6 (diff)
downloadpycparser-a301cbbd55cd3e73c5476f3c1cc3e355dcf30ff0.tar.gz
Drop testing for EOL Pythons 3.2 & 3.3 (#271)
Python 3.2 and 3.3 are end of life. They are no longer receiving bug fixes, including for security issues. Python 3.3 went EOL on 2017-09-29 and Python 3.2 on 2016-02-20. For additional details on supported Python versions, see: https://devguide.python.org/#status-of-python-branches Removing support for EOL Pythons will reduce necessary testing and maintenance resources. Pass python_requires argument to setuptools to help pip decide what version of the library to install. Using pypinfo, here are the download statistics for the last 30 days, showing very minimal use of these EOL pythons: $ pypinfo --percent pycparser pyversion | python_version | percent | download_count | | -------------- | ------- | -------------- | | 2.7 | 71.64% | 1,373,309 | | 3.6 | 15.78% | 302,407 | | 3.5 | 8.32% | 159,452 | | 3.4 | 3.80% | 72,850 | | 2.6 | 0.32% | 6,187 | | 3.7 | 0.12% | 2,263 | | 3.3 | 0.02% | 360 | | 3.2 | 0.00% | 15 | | 3.8 | 0.00% | 5 | | None | 0.00% | 1 |
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 9189712..0fcc191 100644
--- a/setup.py
+++ b/setup.py
@@ -55,12 +55,11 @@ setup(
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
- 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
],
+ python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
packages=['pycparser', 'pycparser.ply'],
package_data={'pycparser': ['*.cfg']},
cmdclass={'install': install, 'sdist': sdist},