summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEli Bendersky <eliben@gmail.com>2023-01-07 08:22:13 -0800
committerEli Bendersky <eliben@gmail.com>2023-01-07 08:22:13 -0800
commitaa325fd47f8c4115e396f5e79d0442666a89b457 (patch)
treef2735cc59c2ff711ffdee8d0a7695bc8777081a7 /setup.py
parentf5ca0284e2c1c9ac2a5be45735735f2f287073cc (diff)
downloadpycparser-aa325fd47f8c4115e396f5e79d0442666a89b457.tar.gz
Start removing support for Python 2.x for pycparser
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 1 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 8dc0cdb..345917b 100644
--- a/setup.py
+++ b/setup.py
@@ -52,19 +52,14 @@ setup(
classifiers = [
'Development Status :: 5 - Production/Stable',
'License :: OSI Approved :: BSD License',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: 3.10',
'Programming Language :: Python :: 3.11',
],
- python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
+ python_requires=">=3.7",
packages=['pycparser', 'pycparser.ply'],
package_data={'pycparser': ['*.cfg']},
cmdclass={'install': install, 'sdist': sdist},