summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobey Pointer <robey@lag.net>2006-08-13 17:52:00 -0700
committerRobey Pointer <robey@lag.net>2006-08-13 17:52:00 -0700
commitc2ef7d6f49efa17da0908409e25a3ca1fc0fc0f8 (patch)
treeeadc34afe8a586350f1eaf939937ca790129e82e
parent1f1909536d0082fc29ba7d53c6226125a7451039 (diff)
downloadpycrypto-c2ef7d6f49efa17da0908409e25a3ca1fc0fc0f8.tar.gz
[project @ robey@lag.net-20060814005200-08740f0447c0d1a8]
patch from amk to point bugs at launchpad
-rw-r--r--README15
-rw-r--r--TODO8
2 files changed, 10 insertions, 13 deletions
diff --git a/README b/README
index c0a134f..b8f9b55 100644
--- a/README
+++ b/README
@@ -7,8 +7,8 @@ package is structured to make adding new modules easy. I consider this
section to be essentially complete, and the software interface will almost
certainly not change in an incompatible way in the future; all that remains
to be done is to fix any bugs that show up. If you encounter a bug, please
-report it in the SourceForge bug tracker at
- https://sourceforge.net/tracker/?group_id=20937&atid=120937
+report it in the Launchpad bug tracker at
+ https://launchpad.net/products/pycrypto/+bugs
An example usage of the MD5 module is:
>>> from Crypto.Hash import MD5
@@ -38,10 +38,6 @@ prototyping and experimentation with cryptographic algorithms; thanks
to its arbitrary-length integers, public key algorithms are easily
implemented.
-Development of the toolkit can be discussed on the pct mailing list;
-archives and instructions for subscribing at at
-<URL:http://www.amk.ca/mailman/listinfo/pct>.
-
Installation
============
@@ -70,7 +66,8 @@ include a patch that fixes it.
To install the package under the site-packages directory of
your Python installation, run "python setup.py install".
-If you have any comments, corrections, or improvements for this package,
-please send it to the 'pct' mailing list. Good luck!
+If you have any comments, corrections, or improvements for this
+package, please report them using the Launchpad site at
+<https://launchpad.net/products/pycrypto>.
---amk (www.amk.ca)
+--amk
diff --git a/TODO b/TODO
index a79ad71..ebd9ef8 100644
--- a/TODO
+++ b/TODO
@@ -1,13 +1,13 @@
+* Rewrite tests to use doctest instead of an obsolete version of Sancho.
+
* Add more tests for random pool code?
-* Manual and Web page: point to SF project for bug reports
+* Manual and Web page: point to Launchpad project for bug reports
* Update documentation (mention dodgy status of PublicKey code)
-* Clean up markup in pycrypt.tex
-
-* Reformat all the code to MEMS Exchange style
+* Clean up markup in pycrypt.tex. Switch to reST, maybe?
* Document the functions and macros for adding a new algorithm
Hash functions: