summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Abramowitz <marc@marc-abramowitz.com>2013-11-10 16:10:30 +0000
committerDwayne Litzenberger <dlitz@dlitz.net>2014-06-22 20:17:48 -0700
commite2e21d74b9b8607a84e612475a4141e2864875cc (patch)
tree321898a8c94365087f710c60c72f8369b0b368b3
parentf070adf984c6bb3ef72a3bf3d05648ea304eaa61 (diff)
downloadpycrypto-e2e21d74b9b8607a84e612475a4141e2864875cc.tar.gz
Add support for tox
-rw-r--r--.gitignore3
-rw-r--r--tox.ini10
2 files changed, 13 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index f4ba81d..0672b58 100644
--- a/.gitignore
+++ b/.gitignore
@@ -24,3 +24,6 @@ src/stamp-h1
# Backup files
*~
+
+# Tox
+.tox
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..56738d4
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,10 @@
+# Tox (http://tox.testrun.org/) is a tool for running tests
+# in multiple virtualenvs. This configuration file will run the
+# test suite on all supported python versions. To use it, "pip install tox"
+# and then run "tox" from this directory.
+
+[tox]
+envlist = py25, py26, py27, py32, py33, py34, pypy
+
+[testenv]
+commands = {envpython} setup.py test