summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDwayne Litzenberger <dlitz@dlitz.net>2014-06-22 23:47:49 -0700
committerDwayne Litzenberger <dlitz@dlitz.net>2014-06-22 23:47:49 -0700
commitfc266f4ae9138022df4808e19c579c8a5c60f24b (patch)
tree6dbfe606129f562cbc6820e23cb823a29e1c1ade
parent947b554d85012cf35185ded38ef3484de010d2cf (diff)
downloadpycrypto-fc266f4ae9138022df4808e19c579c8a5c60f24b.tar.gz
Update configure script from configure.ac
-rwxr-xr-xconfigure38
1 files changed, 38 insertions, 0 deletions
diff --git a/configure b/configure
index 6656298..f4fd00b 100755
--- a/configure
+++ b/configure
@@ -2997,6 +2997,7 @@ END
fi
fi
+
# Checks for programs.
DEPDIR="${am__leading_dot}deps"
@@ -5298,6 +5299,43 @@ _ACEOF
esac
+ ac_fn_c_check_type "$LINENO" "uintptr_t" "ac_cv_type_uintptr_t" "$ac_includes_default"
+if test "x$ac_cv_type_uintptr_t" = xyes; then :
+
+$as_echo "#define HAVE_UINTPTR_T 1" >>confdefs.h
+
+else
+ for ac_type in 'unsigned int' 'unsigned long int' \
+ 'unsigned long long int'; do
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+/* end confdefs.h. */
+$ac_includes_default
+int
+main ()
+{
+static int test_array [1 - 2 * !(sizeof (void *) <= sizeof ($ac_type))];
+test_array [0] = 0;
+return test_array [0];
+
+ ;
+ return 0;
+}
+_ACEOF
+if ac_fn_c_try_compile "$LINENO"; then :
+
+cat >>confdefs.h <<_ACEOF
+#define uintptr_t $ac_type
+_ACEOF
+
+ ac_type=
+fi
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+ test -z "$ac_type" && break
+ done
+fi
+
+
+
# Checks for library functions.
for ac_header in stdlib.h
do :