summaryrefslogtreecommitdiff
path: root/ChangeLog
diff options
context:
space:
mode:
authorDwayne C. Litzenberger <dlitz@dlitz.net>2012-01-13 11:58:17 -0500
committerDwayne C. Litzenberger <dlitz@dlitz.net>2012-01-13 11:58:17 -0500
commit3caf71013d7f293962b67cdaae8e5350d4858679 (patch)
tree99f54df8d4be123baeacc25181a5aa691653b0f2 /ChangeLog
parent5feb3e1c46bdeeeaf2f2c307a66bedc900fe1f30 (diff)
downloadpycrypto-3caf71013d7f293962b67cdaae8e5350d4858679.tar.gz
Update ChangeLog
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog33
1 files changed, 33 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 6aaf69e..017a8d0 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,36 @@
+2.5
+===
+ * Added PKCS#1 encryption schemes (v1.5 and OAEP). We now have
+ a decent, easy-to-use non-textbook RSA implementation. Yay!
+
+ * Added PKCS#1 signature schemes (v1.5 and PSS). v1.5 required some
+ extensive changes to Hash modules to contain the algorithm specific
+ ASN.1 OID. To that end, we now always have a (thin) Python module to
+ hide the one in pure C.
+
+ * Added 2 standard Key Derivation Functions (PBKDF1 and PBKDF2).
+
+ * Added export/import of RSA keys in OpenSSH and PKCS#8 formats.
+
+ * Added password-protected export/import of RSA keys (one old method
+ for PKCS#8 PEM only).
+
+ * Added ability to generate RSA key pairs with configurable public
+ exponent e.
+
+ * Added ability to construct an RSA key pair even if only the private
+ exponent d is known, and not p and q.
+
+ * Added SHA-2 C source code (fully from Lorenz Quack).
+
+ * Unit tests for all the above.
+
+ * Updates to documentation (both inline and in Doc/pycrypt.rst)
+
+ * All of the above changes were put together by Legrandin (Thanks!)
+
+ * Minor bug fixes (setup.py and tests).
+
2.4.1
=====
* Fix "error: Setup script exited with error: src/config.h: No such file or