summaryrefslogtreecommitdiff
path: root/README
diff options
context:
space:
mode:
authorLegrandin <gooksankoo@hoiptorrow.mailexpire.com>2011-01-10 18:52:40 +0100
committerLegrandin <gooksankoo@hoiptorrow.mailexpire.com>2011-01-10 18:52:40 +0100
commitabd276c5fa31abf0b1d70ca4624e30cdacaee867 (patch)
tree4522ec6ad8926e9d382947c586a3305ca337b9d0 /README
parent3c193d7b1097eac78592e22e1cad4f4249f7d9d3 (diff)
downloadpycrypto-abd276c5fa31abf0b1d70ca4624e30cdacaee867.tar.gz
Improve the test command in setup.py, by allowing tests to be
performed on a single sub-package or module only.
Diffstat (limited to 'README')
-rw-r--r--README7
1 files changed, 7 insertions, 0 deletions
diff --git a/README b/README
index 7196b63..212d4e6 100644
--- a/README
+++ b/README
@@ -86,6 +86,13 @@ possible, track down the bug and include a patch that fixes it,
provided that you are able to meet the eligibility requirements at
http://www.pycrypto.org/submission-requirements/.
+It is possible to test a single sub-package or a single module only, for instance
+when you investigate why certain tests fail and don't want to run the whole
+suite each time. Use "python setup.py test --module=name", where 'name'
+is either a sub-package (Cipher, PublicKey, etc) or a module (Cipher.DES,
+PublicKey.RSA, etc).
+To further cut test coverage, pass also the option "--skip-slow-tests".
+
To install the package under the site-packages directory of
your Python installation, run "python setup.py install".