summaryrefslogtreecommitdiff
path: root/bootstrap.sh
diff options
context:
space:
mode:
authorDwayne Litzenberger <dlitz@dlitz.net>2013-02-02 20:48:04 -0800
committerDwayne Litzenberger <dlitz@dlitz.net>2013-02-16 13:09:42 -0800
commit95918a1a86bc1e4c5045801b4bdb83359e033c6a (patch)
treec594383bae412a70e930c6f37040fb8d34572de2 /bootstrap.sh
parent6e3d2bdcc0e2a97f56f69c77b8acd1fbd80eaa45 (diff)
downloadpycrypto-95918a1a86bc1e4c5045801b4bdb83359e033c6a.tar.gz
Use autoconf to generate compiler options
Hopefully this means we'll break on fewer platforms. Also, remove some of the extra optimization flags (e.g. -O3 -fomit-frame-pointer), which don't really do much.
Diffstat (limited to 'bootstrap.sh')
-rwxr-xr-xbootstrap.sh12
1 files changed, 9 insertions, 3 deletions
diff --git a/bootstrap.sh b/bootstrap.sh
index e7ba88a..bf2fae6 100755
--- a/bootstrap.sh
+++ b/bootstrap.sh
@@ -2,6 +2,12 @@
# Generates ./src/config.h.in and ./configure
set -e
-aclocal
-autoheader
-autoconf
+aclocal --force -I m4
+autoconf --force
+autoheader --force
+
+# The following line is needed to generate build-aux/*, but it will fail
+# because we have no Makefile.am
+mkdir -p build-aux
+echo "** You can ignore the following error about a missing Makefile.am"
+automake --add-missing --copy || true