summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authoroxc <github@nospam.obeliks.de>2012-01-29 13:07:29 +0100
committeroxc <github@nospam.obeliks.de>2012-01-29 13:07:29 +0100
commit121de172851876c050e867379f5623591b85b7fc (patch)
treea2647652ce34066df99f6a0f0a8986d88a1aeeb2 /configure.ac
parent20ee9299355915891bd6326e05b991267af95d34 (diff)
downloadpycrypto-121de172851876c050e867379f5623591b85b7fc.tar.gz
Remove automagic dependencies on libgmp and libmpir, let the caller disable them using args.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2b68d71..b45655d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,8 +10,16 @@ AC_CONFIG_HEADERS([src/config.h])
AC_PROG_CC
# Checks for libraries.
-AC_CHECK_LIB([gmp], [__gmpz_init])
-AC_CHECK_LIB([mpir], [__gmpz_init])
+AC_ARG_WITH([gmp], AS_HELP_STRING([--without-gmp], [Build without gmp library (default: test)]))
+AS_IF([test "x$with_gmp" != "xno"], [
+ AC_CHECK_LIB([gmp], [__gmpz_init])
+])
+
+AC_ARG_WITH([mpir], AS_HELP_STRING([--without-mpir], [Build without mpir library (default: test)]))
+AS_IF([test "x$with_mpir" != "xno"], [
+ AC_CHECK_LIB([mpir], [__gmpz_init])
+])
+
AC_CHECK_DECLS([mpz_powm], [], [], [
[#if HAVE_LIBGMP
# include <gmp.h>