summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Ramacher <sebastian+dev@ramacher.at>2013-10-28 02:52:39 +0100
committerSebastian Ramacher <sebastian+dev@ramacher.at>2013-10-28 17:57:36 +0100
commit8b68505248a54477f7cb81b30e33520d9c5d1083 (patch)
treed7c3f7b766ffa99f8edf4105d3ae8f907edde473 /configure.ac
parent8cde8b9893819e9586bde2ce9be84f24689ff0d9 (diff)
downloadpycrypto-8b68505248a54477f7cb81b30e33520d9c5d1083.tar.gz
Make sure that ek and dk are aligned at 16 byte boundaries
ek and dk are used as operands in instructions that require 16 byte alignment. Thanks to Greg Price for finding this issue. Signed-off-by: Sebastian Ramacher <sebastian+dev@ramacher.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b62db5e..5f22d00 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,5 +103,6 @@ AC_TYPE_UINT8_T
# Checks for library functions.
AC_FUNC_MALLOC
AC_CHECK_FUNCS([memmove memset])
+AC_CHECK_FUNCS([posix_memalign aligned_alloc _aligned_malloc])
AC_OUTPUT