summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLegrandin <gooksankoo@hoiptorrow.mailexpire.com>2011-12-22 14:55:40 +0100
committerLegrandin <gooksankoo@hoiptorrow.mailexpire.com>2011-12-22 14:55:40 +0100
commit114ca5b4d467617489817eee77ed0621665ee362 (patch)
tree982344b2853ada3508961cf7383a524eb2b4cbbc /setup.py
parentdb6f4555e60b48a3b9ffa232061d460c3c18a06f (diff)
parent6fedd15136e8de6a98c46cd1d92c6e6cf2790fae (diff)
downloadpycrypto-114ca5b4d467617489817eee77ed0621665ee362.tar.gz
Merge from upstream
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 9 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index cf258fa..7085879 100644
--- a/setup.py
+++ b/setup.py
@@ -242,12 +242,17 @@ class PCTBuildExt (build_ext):
f.close()
return result
-class PCTBuild(build):
+ def run(self):
+ for cmd_name in self.get_sub_commands():
+ self.run_command(cmd_name)
+
+ build_ext.run(self)
+
def has_configure(self):
compiler = new_compiler(compiler=self.compiler)
return compiler.compiler_type != 'msvc'
- sub_commands = [ ('build_configure', has_configure) ] + build.sub_commands
+ sub_commands = [ ('build_configure', has_configure) ] + build_ext.sub_commands
class PCTBuildConfigure(Command):
description = "Generate config.h using ./configure (autoconf)"
@@ -333,13 +338,13 @@ class TestCommand(Command):
self.announce("running extended self-tests")
kw = {'name':"pycrypto",
- 'version':"2.3", # See also: lib/Crypto/__init__.py
+ 'version':"2.4.1", # See also: lib/Crypto/__init__.py
'description':"Cryptographic modules for Python.",
'author':"Dwayne C. Litzenberger",
'author_email':"dlitz@dlitz.net",
'url':"http://www.pycrypto.org/",
- 'cmdclass' : {'build': PCTBuild, 'build_configure': PCTBuildConfigure, 'build_ext':PCTBuildExt, 'build_py': PCTBuildPy, 'test': TestCommand },
+ 'cmdclass' : {'build_configure': PCTBuildConfigure, 'build_ext': PCTBuildExt, 'build_py': PCTBuildPy, 'test': TestCommand },
'packages' : ["Crypto", "Crypto.Hash", "Crypto.Cipher", "Crypto.Util",
"Crypto.Random",
"Crypto.Random.Fortuna",