summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDwayne C. Litzenberger <dlitz@dlitz.net>2012-07-03 12:16:53 -0400
committerDwayne C. Litzenberger <dlitz@dlitz.net>2012-07-03 12:16:53 -0400
commit3103b3789fb26d9cf9aba2d27f6458fc072ed85a (patch)
treec10e8a49763e66ab816247546a8a0e8137a6a33e /setup.py
parentdaed1020833cb3c3258600300e48244e27ade086 (diff)
downloadpycrypto-3103b3789fb26d9cf9aba2d27f6458fc072ed85a.tar.gz
setup.py: Add more compiler warnings and fix unsigned-signed comparisons
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index a3d812f..0334939 100644
--- a/setup.py
+++ b/setup.py
@@ -117,6 +117,11 @@ class PCTBuildExt (build_ext):
# Tell GCC to compile using the C99 standard.
self.__add_compiler_option("-std=c99")
+ # More compiler warnings
+ self.__add_compiler_option("-Wextra")
+ self.__add_compiler_option("-Wno-missing-field-initializers")
+ self.__add_compiler_option("-Wno-unused-parameter")
+
# ... but don't tell that to the aCC compiler on HP-UX
if self.compiler.compiler_so[0] == 'cc' and sys.platform.startswith('hp-ux'):
self.__remove_compiler_option("-std=c99")