summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDwayne C. Litzenberger <dlitz@dlitz.net>2008-09-12 15:26:24 -0400
committerDwayne C. Litzenberger <dlitz@dlitz.net>2008-09-12 17:44:49 -0400
commit5a9d81923333be5642371a9614f328297f8d09bc (patch)
treed0e0f0f2822665628c90c4200b27fc533f78817a /setup.py
parent140a3edc0a3fdb95fad809a0e1d9a5427eda2bb1 (diff)
downloadpycrypto-5a9d81923333be5642371a9614f328297f8d09bc.tar.gz
SelfTest: Add Crypto.SelfTest framework and hash tests
Rewritten from scratch to be clean, flexible, and compatible with Python 2.1.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 25ea9eb..7d11b76 100644
--- a/setup.py
+++ b/setup.py
@@ -157,6 +157,8 @@ kw = {'name':"pycrypto",
'cmdclass' : {'build_ext':PCTBuildExt, 'build_py': PCTBuildPy},
'packages' : ["Crypto", "Crypto.Hash", "Crypto.Cipher", "Crypto.Util",
+ "Crypto.SelfTest",
+ "Crypto.SelfTest.Hash",
"Crypto.Protocol", "Crypto.PublicKey"],
'package_dir' : { "Crypto":"." },
# One module is defined here, because build_ext won't be