summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDwayne C. Litzenberger <dlitz@dlitz.net>2009-03-01 09:51:00 -0500
committerDwayne C. Litzenberger <dlitz@dlitz.net>2009-03-01 10:23:13 -0500
commit5b5b496c0f81f3595d0aebb8da5196492abae429 (patch)
tree63cb94ef764d0dc2b603e34951f7d42f73ae4ef6 /setup.py
parent494cad8bc9a706aeb721098e8e1cd19c26d84466 (diff)
downloadpycrypto-5b5b496c0f81f3595d0aebb8da5196492abae429.tar.gz
Remove Blowfish, DES, DES3, IDEA, RC5, and XOR modules
Because: - Blowfish: Uses the original (ambiguous) PyCrypto license. The documentation says "the Blowfish algorithm has been placed in the public domain and can be used freely", but this seems to be referring to patents, not copyright. - DES: The file says "Copyright (C) 1993 Eric Young", and appears to have been taken from SSLeay. The license of SSLeay is not GPL-compatible, since it has an advertising clause. - DES3: Same reason as for the DES module. - IDEA: Patent-encumbered. - RC5: Patent-encumbered. - XOR: Insecure as a stream cipher, and it silently truncates "keys" to 32 bytes. The strxor module is a better replacement if you want to do a bitwise exclusive-or between strings.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 9 insertions, 19 deletions
diff --git a/setup.py b/setup.py
index 335987d..9e20d2d 100644
--- a/setup.py
+++ b/setup.py
@@ -99,33 +99,23 @@ class PCTBuildExt (build_ext):
Extension("Crypto.Cipher.ARC2",
include_dirs=['src/'],
sources=["src/ARC2.c"]),
- Extension("Crypto.Cipher.Blowfish",
- include_dirs=['src/'],
- sources=["src/Blowfish.c"]),
+# Extension("Crypto.Cipher.Blowfish",
+# include_dirs=['src/'],
+# sources=["src/Blowfish.c"]),
Extension("Crypto.Cipher.CAST",
include_dirs=['src/'],
sources=["src/CAST.c"]),
- Extension("Crypto.Cipher.DES",
- include_dirs=['src/'],
- sources=["src/DES.c"]),
- Extension("Crypto.Cipher.DES3",
- include_dirs=['src/'],
- sources=["src/DES3.c"]),
- Extension("Crypto.Cipher.IDEA",
- include_dirs=['src/'],
- sources=["src/IDEA.c"],
- libraries=HTONS_LIBS),
- Extension("Crypto.Cipher.RC5",
- include_dirs=['src/'],
- sources=["src/RC5.c"]),
+# Extension("Crypto.Cipher.DES",
+# include_dirs=['src/'],
+# sources=["src/DES.c"]),
+# Extension("Crypto.Cipher.DES3",
+# include_dirs=['src/'],
+# sources=["src/DES3.c"]),
# Stream ciphers
Extension("Crypto.Cipher.ARC4",
include_dirs=['src/'],
sources=["src/ARC4.c"]),
- Extension("Crypto.Cipher.XOR",
- include_dirs=['src/'],
- sources=["src/XOR.c"]),
# Utility modules
Extension("Crypto.Util.strxor",