summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLegrandin <gooksankoo@hoiptorrow.mailexpire.com>2012-05-09 20:55:07 +0200
committerLegrandin <gooksankoo@hoiptorrow.mailexpire.com>2012-05-10 19:16:50 +0200
commit6f9fe103a582999c397f7bc8a2248613a207b780 (patch)
treec7f1bcf72442b2392d078d4a38e8bd9761bb39da /setup.py
parent2f8a86bd83138bfef618e763fb8b2147f1214af8 (diff)
downloadpycrypto-6f9fe103a582999c397f7bc8a2248613a207b780.tar.gz
Added documentation for AES and DES.
A new module (blockalgo) has been added. It contains a class (BlockAlgo) all ciphers derive from. The only purpose of such base class is to centralize all general documentation applicable to all block ciphers (e.g. modes) into a single file.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index dd05abc..8a22b6e 100644
--- a/setup.py
+++ b/setup.py
@@ -395,7 +395,7 @@ kw = {'name':"pycrypto",
define_macros=[endianness_macro()]),
# Block encryption algorithms
- Extension("Crypto.Cipher.AES",
+ Extension("Crypto.Cipher._AES",
include_dirs=['src/'],
sources=["src/AES.c"]),
Extension("Crypto.Cipher.ARC2",
@@ -407,7 +407,7 @@ kw = {'name':"pycrypto",
Extension("Crypto.Cipher.CAST",
include_dirs=['src/'],
sources=["src/CAST.c"]),
- Extension("Crypto.Cipher.DES",
+ Extension("Crypto.Cipher._DES",
include_dirs=['src/', 'src/libtom/'],
sources=["src/DES.c"]),
Extension("Crypto.Cipher.DES3",