summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDwayne C. Litzenberger <dlitz@dlitz.net>2011-10-10 15:33:59 -0400
committerDwayne C. Litzenberger <dlitz@dlitz.net>2011-10-10 16:05:23 -0400
commit7e490d9b3ae75bea53d600cff6cef9f9dec08003 (patch)
treeb0164c531845e6b48ab8603354c29da3eae058e2 /setup.py
parentc263294fe7707abec2550275a8c6dc994869f3b8 (diff)
downloadpycrypto-7e490d9b3ae75bea53d600cff6cef9f9dec08003.tar.gz
setup.py: configure be quiet when --quiet is specified
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0021980..91478cb 100644
--- a/setup.py
+++ b/setup.py
@@ -268,7 +268,11 @@ class PCTBuildConfigure(Command):
if not os.path.exists("config.status"):
if os.system("chmod 0755 configure") != 0:
raise RuntimeError("chmod error")
- if os.system("./configure") != 0:
+ if self.verbose < 1:
+ cmd = "./configure -q"
+ else:
+ cmd = "./configure"
+ if os.system(cmd) != 0:
raise RuntimeError("autoconf error")
class PCTBuildPy(build_py):