summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLegrandin <helderijs@gmail.com>2013-06-15 23:25:49 +0200
committerDwayne Litzenberger <dlitz@dlitz.net>2013-07-14 21:16:46 -0700
commit90d6d3dbcfb02fc441edafe6fafe6e6800009e35 (patch)
treea47b22eea2560392a673d8cba675579459452482 /setup.py
parent5a0ee14e9904335cb90c0dd7a4e10f1523435c52 (diff)
downloadpycrypto-90d6d3dbcfb02fc441edafe6fafe6e6800009e35.tar.gz
Added support for PKCS#8-encrypted private keys.
The patch contains the following changes: - Private RSA keys can be imported/exported in encrypted form, protected according to PKCS#8 and: * PBKDF2WithHMAC-SHA1AndDES-EDE3-CBC. * PBKDF2WithHMAC-SHA1AndAES128-CBC * PBKDF2WithHMAC-SHA1AndAES192-CBC * PBKDF2WithHMAC-SHA1AndAES256-CBC In addition to that, it is possible to import keys i the following weak formats: * pbeWithMD5AndDES-CBC * pbeWithSHA1AndRC2-CBC * pbeWithMD5AndRC2-CBC * pbeWithSHA1AndDES-CBC - The following new module (and 1 new package) are added: * Crypto.Util.Padding for simple padding/unpadding logic * Crypto.IO._PBES for PBE-related PKCS#5 logic * Crypto.IO.PEM for PEM wrapping/unwrapping * Crypto.IO.PKCS8 for PKCS#8 wrapping/unwrapping - All Object ID (OIDs) are now in dotted form to increase readability. - Add AES support to PEM format (decode only). The PEM module can decrypt messages protected with AES-CBC. - Update RSA import test cases. - Updated to PKCS8 test cases
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 5af83ac..903a81f 100644
--- a/setup.py
+++ b/setup.py
@@ -402,9 +402,11 @@ kw = {'name':"pycrypto",
"Crypto.SelfTest.Random.OSRNG",
"Crypto.SelfTest.Util",
"Crypto.SelfTest.Signature",
+ "Crypto.SelfTest.IO",
"Crypto.Protocol",
"Crypto.PublicKey",
- "Crypto.Signature"],
+ "Crypto.Signature",
+ "Crypto.IO"],
'package_dir' : { "Crypto": "lib/Crypto" },
'ext_modules': plat_ext + [
# _fastmath (uses GNU mp library)