summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDwayne C. Litzenberger <dlitz@dlitz.net>2008-08-13 13:10:57 -0400
committerDwayne C. Litzenberger <dlitz@dlitz.net>2008-09-15 23:01:28 -0400
commitca154534978f90e0931e16a4423601a8404dbd23 (patch)
tree3382e5ff3c79a5a752f38ecc779f805dc54d3d3c /setup.py
parent45d090f349805a44759ed02b925faccce6e593e0 (diff)
downloadpycrypto-ca154534978f90e0931e16a4423601a8404dbd23.tar.gz
RIPEMD: Remove the old RIPEMD.c module due to copyright concerns
The copyright notice and disclaimer at the top of RIPEMD.c says: Copyright (c) Katholieke Universiteit Leuven 1996, All Rights Reserved The Katholieke Universiteit Leuven makes no representations concerning either the merchantability of this software or the suitability of this software for any particular purpose. It is provided "as is" without express or implied warranty of any kind. These notices must be retained in any copies of any part of this documentation and/or software. To me, it seems as though the software was intended to be freely distributed, as long as the notice and disclaimer are included. However, no such permission is explicitly granted, so I am removing the module (without looking at its contents).
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 0 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 8c4e9c5..a48957a 100644
--- a/setup.py
+++ b/setup.py
@@ -75,10 +75,6 @@ class PCTBuildExt (build_ext):
Extension("Crypto.Hash.MD4",
include_dirs=['src/'],
sources=["src/MD4.c"]),
- Extension("Crypto.Hash.RIPEMD",
- include_dirs=['src/'],
- sources=["src/RIPEMD.c"],
- libraries=HTONS_LIBS),
Extension("Crypto.Hash.SHA256",
include_dirs=['src/'],
sources=["src/SHA256.c"]),