summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorThorsten Behrens <sbehrens@gmx.li>2010-12-29 13:21:05 -0500
committerThorsten Behrens <sbehrens@gmx.li>2010-12-29 13:21:05 -0500
commitcb48387f66a7fe9c2450b740a84c3c5af3712895 (patch)
treed0f94e44d8ae02f8d44e728cdadfa9befec66485 /src
parentca701f92f538ddd61835a2ec252ebbb8a0b1e4de (diff)
downloadpycrypto-cb48387f66a7fe9c2450b740a84c3c5af3712895.tar.gz
PY3K _fastmath support
o _fastmath now builds and runs on PY3K o Changes to setup.py to allow /usr/include for gmp.h o Changes to setup.py to allow linking fastmath w/ static mpir on Windows without warning messages o Changes to test_DSA/test_RSA to throw an exception if _fastmath is present but cannot be imported (due to an issue building _fastmath or the shared gmp/mpir libraries not being reachable) o number.py has the code to flag a failing _fastmath, but that code is commented out for a better runtime experience o Clean up the if for py21compat import - should have been == not is o Clean up some '== None' occurences, now 'is None' instead
Diffstat (limited to 'src')
-rwxr-xr-xsrc/_fastmath.c1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/_fastmath.c b/src/_fastmath.c
index f3922cf..fe3fde3 100755
--- a/src/_fastmath.c
+++ b/src/_fastmath.c
@@ -1,4 +1,3 @@
-
/*
* _fastmath.c: Accelerator module that uses GMP for faster numerics.
*