summaryrefslogtreecommitdiff
path: root/tools/test-all.sh
diff options
context:
space:
mode:
authorDwayne Litzenberger <dlitz@dlitz.net>2013-02-02 19:28:50 -0800
committerDwayne Litzenberger <dlitz@dlitz.net>2013-02-02 19:29:05 -0800
commit48e2b718aeefb35caac8498cf4dbbd3a12e8ba83 (patch)
treed4f217495436c500363a0900fa6a863bfca23a8e /tools/test-all.sh
parent07fae6821c0f2bfe04e73b30f82483ce32465e8f (diff)
downloadpycrypto-48e2b718aeefb35caac8498cf4dbbd3a12e8ba83.tar.gz
Check in some scripts I use for building and testing against multiple versions of Python
Diffstat (limited to 'tools/test-all.sh')
-rwxr-xr-xtools/test-all.sh33
1 files changed, 33 insertions, 0 deletions
diff --git a/tools/test-all.sh b/tools/test-all.sh
new file mode 100755
index 0000000..ae3c88c
--- /dev/null
+++ b/tools/test-all.sh
@@ -0,0 +1,33 @@
+#!/bin/bash
+# Script used to build PyCrypto under all Python versions
+# Edit it to suit your needs.
+# by Dwayne Litzenberger
+#
+# The contents of this file are dedicated to the public domain. To
+# the extent that dedication to the public domain is not available,
+# everyone is granted a worldwide, perpetual, royalty-free,
+# non-exclusive license to exercise all rights associated with the
+# contents of this file for any purpose whatsoever.
+# No rights are reserved.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
+# BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
+# ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+#
+
+set -e
+PREFIX=${PREFIX:-$(dirname "$(readlink -f "$0")")/py}
+
+export -n PREFIX # unexport
+
+find "$PREFIX"/pythons/python* -maxdepth 0 -type d -print0 | sort -z | while IFS= read -d '' -r pythondir
+do
+ echo "=== `basename $pythondir` ==="
+ "$pythondir"/bin/python?.? setup.py -q build
+ "$pythondir"/bin/python?.? setup.py -q test
+done