summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog5
-rw-r--r--Doc/pycrypt.rst2
-rw-r--r--lib/Crypto/__init__.py2
-rw-r--r--setup.py2
4 files changed, 8 insertions, 3 deletions
diff --git a/ChangeLog b/ChangeLog
index b112a20..6aaf69e 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+2.4.1
+=====
+ * Fix "error: Setup script exited with error: src/config.h: No such file or
+ directory" when installing via easy_install. (Sebastian Ramacher)
+
2.4
===
* Python 3 support! (Thorsten E. Behrens, Anders Sundman)
diff --git a/Doc/pycrypt.rst b/Doc/pycrypt.rst
index d74bf0c..02234af 100644
--- a/Doc/pycrypt.rst
+++ b/Doc/pycrypt.rst
@@ -2,7 +2,7 @@
Python Cryptography Toolkit
====================================
-**Version 2.4**
+**Version 2.4.1**
The Python Cryptography Toolkit describes a package containing various
cryptographic modules for the Python programming language. This
diff --git a/lib/Crypto/__init__.py b/lib/Crypto/__init__.py
index 56e4c67..19c645b 100644
--- a/lib/Crypto/__init__.py
+++ b/lib/Crypto/__init__.py
@@ -38,7 +38,7 @@ Crypto.Util Various useful modules and functions (long-to-string
__all__ = ['Cipher', 'Hash', 'Protocol', 'PublicKey', 'Util']
-__version__ = '2.4' # See also below and setup.py
+__version__ = '2.4.1' # See also below and setup.py
__revision__ = "$Id$"
# New software should look at this instead of at __version__ above.
diff --git a/setup.py b/setup.py
index a822938..cda9950 100644
--- a/setup.py
+++ b/setup.py
@@ -383,7 +383,7 @@ class TestCommand(Command):
self.announce("running extended self-tests")
kw = {'name':"pycrypto",
- 'version':"2.4", # See also: lib/Crypto/__init__.py
+ 'version':"2.4.1", # See also: lib/Crypto/__init__.py
'description':"Cryptographic modules for Python.",
'author':"Dwayne C. Litzenberger",
'author_email':"dlitz@dlitz.net",