summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore3
-rw-r--r--tox.ini10
2 files changed, 13 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index f4ba81d..0672b58 100644
--- a/.gitignore
+++ b/.gitignore
@@ -24,3 +24,6 @@ src/stamp-h1
# Backup files
*~
+
+# Tox
+.tox
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..56738d4
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,10 @@
+# Tox (http://tox.testrun.org/) is a tool for running tests
+# in multiple virtualenvs. This configuration file will run the
+# test suite on all supported python versions. To use it, "pip install tox"
+# and then run "tox" from this directory.
+
+[tox]
+envlist = py25, py26, py27, py32, py33, py34, pypy
+
+[testenv]
+commands = {envpython} setup.py test