summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTushar Gohad <tushar.gohad@intel.com>2015-09-06 06:46:42 +0000
committerTushar Gohad <tushar.gohad@intel.com>2015-09-08 02:39:09 +0000
commitb1c63c6a34cfa0a3679c5081c95a50ba324c5004 (patch)
treeaf5dbcfe66b41c1fee139c8cbf46e74b1689e6fa
parent1a9426971c9d8e8b359b8e2586ec8c75258502ec (diff)
downloadpyeclib-release_1.0.9.tar.gz
Release 1.0.9release_1.0.9
-rw-r--r--ChangeLog18
-rw-r--r--setup.py2
2 files changed, 19 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index 48fe332..71f1165 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,21 @@
+New in 1.0.9
+------------
+
+ * Eliminate rpath handling in setup.py
+
+ * Clean py34 shared libraries created during build
+
+ * Fix integer truncation issue with PyBuildValue on Big Endian
+ systems by explicitly casting the size argument passed in to
+ Py_ssize_t. Also fix import issue with the API test where
+ older versions of Python fail to import.
+
+ * Add --install-liberasurecode option to setup.py. Requested
+ by Red Hat/Debian package maintainers.
+
+ * Update bundled liberasurecode version to 1.0.9
+
+
New in 1.0.8
------------
diff --git a/setup.py b/setup.py
index 7fecc1b..5143348 100644
--- a/setup.py
+++ b/setup.py
@@ -304,7 +304,7 @@ module = Extension('pyeclib_c',
sources=['src/c/pyeclib_c/pyeclib_c.c'])
setup(name='PyECLib',
- version='1.0.8',
+ version='1.0.9',
author='Kevin Greenan',
author_email='kmgreen2@gmail.com',
maintainer='Kevin Greenan and Tushar Gohad',