summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin Greenan <kmgreen2@gmail.com>2016-01-12 17:03:17 -0800
committerKevin Greenan <kmgreen2@gmail.com>2016-01-12 17:03:17 -0800
commit19c99357839b0b95053632f303c1c4fab5408450 (patch)
tree36a70e258c371e57cb2f5d612029734ad89e8f23
parente4c48eec2a3fbda80d8a0503a2721df2d9b020a5 (diff)
parent10eca220188b1b55cc80eebc097f59e0b348b941 (diff)
downloadpyeclib-1.2.0.tar.gz
Merged v1.2.0 into masterv1.2.0
-rw-r--r--ChangeLog19
-rw-r--r--README4
-rw-r--r--setup.py4
3 files changed, 23 insertions, 4 deletions
diff --git a/ChangeLog b/ChangeLog
index e60153d..1d5c837 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,22 @@
+New in 1.2.0
+------------
+
+ * Remove integrated liberasurecode - the prereq library is now
+ available in major deb/rpm based distros
+
+ * Eliminate liberasurecode-related rpath checks, library searches
+ and architecture validation
+
+ * Changes for compatibility with liberasurecode versions prior to
+ 1.1.0
+
+ * Make VALID_EC_TYPES a runtime property - dynamically look for
+ liberasurecode EC schemes available at runtime
+
+ * More comprehensive unit test coverage
+
+ * Add travis-ci build config for automated build/tests
+
New in 1.1.0
------------
diff --git a/README b/README
index b6dd7ff..97da5a8 100644
--- a/README
+++ b/README
@@ -1,4 +1,4 @@
-This is v1.1 of PyECLib. This library provides a simple Python interface for
+This is v1.2 of PyECLib. This library provides a simple Python interface for
implementing erasure codes and is known to work with Python v2.6, 2.7 and 3.x.
To obtain the best possible performance, the library utilizes liberasurecode,
@@ -266,4 +266,4 @@ References
[5] Kota Tsuyuzaki <tsuyuzaki.kota@lab.ntt.co.jp>, Ryuta Kon <kon.ryuta@po.ntts.co.jp>, "NTT SHSS Erasure Coding backend"
--
-1.1
+1.2
diff --git a/setup.py b/setup.py
index 2548d45..b3047f2 100644
--- a/setup.py
+++ b/setup.py
@@ -169,7 +169,7 @@ class install(_install):
module = Extension('pyeclib_c',
define_macros=[('MAJOR VERSION', '1'),
- ('MINOR VERSION', '1')],
+ ('MINOR VERSION', '2')],
include_dirs=[default_python_incdir,
'src/c/pyeclib_c',
'/usr/include',
@@ -182,7 +182,7 @@ module = Extension('pyeclib_c',
sources=['src/c/pyeclib_c/pyeclib_c.c'])
setup(name='PyECLib',
- version='1.1.1',
+ version='1.2.0',
author='Kevin Greenan',
author_email='kmgreen2@gmail.com',
maintainer='Kevin Greenan and Tushar Gohad',