summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThiago da Silva <thiago@redhat.com>2017-06-06 21:11:00 -0400
committerThiago da Silva <thiago@redhat.com>2017-06-06 21:11:13 -0400
commit0cdfbf6f6eaf2a4f67c83d4019614cde414ca2f9 (patch)
treedff7db9ff6c7016250c965b5650b2e28b3afeb19
parent4e0f35a34d4aa10fd98ae8d3bbc9cecaf43601d4 (diff)
downloadpyeclib-0cdfbf6f6eaf2a4f67c83d4019614cde414ca2f9.tar.gz
Release 1.5.01.5.0
Change-Id: Id6ea5043c983ec0f882feedb6c970e3994961d6c
-rw-r--r--.mailmap1
-rw-r--r--AUTHORS20
-rw-r--r--ChangeLog11
-rw-r--r--doc/source/conf.py4
-rw-r--r--setup.py4
5 files changed, 27 insertions, 13 deletions
diff --git a/.mailmap b/.mailmap
index a773e65..8f65196 100644
--- a/.mailmap
+++ b/.mailmap
@@ -5,3 +5,4 @@ Tushar Gohad <tushar.gohad@intel.com> <tusharsg@gmail.com>
Tushar Gohad <tushar.gohad@intel.com> <Tushar Gohad>
Eric Lambert <eric_lambert@xyratex.com> <eric.lambert@seagate.com>
Kota Tsuyuzaki <bloodeagle40234@gmail.com> <tsuyuzaki.kota@lab.ntt.co.jp>
+Kota Tsuyuzaki <bloodeagle40234@gmail.com> <bloodeagle40123@gmail.com>
diff --git a/AUTHORS b/AUTHORS
index 818d992..bba00a2 100644
--- a/AUTHORS
+++ b/AUTHORS
@@ -1,18 +1,22 @@
Original Authors
----------------
-Tushar Gohad (tushar.gohad@intel.com)
Kevin Greenan (kmgreen2@gmail.com)
+Tushar Gohad (tushar.gohad@intel.com)
Contributors
------------
-Timur Alperovich (timuralp@swiftstack.com)
-Tim Burke (tim.burke@gmail.com)
-Thiago da Silva (thiago@redhat.com)
-Eric Lambert (eric_lambert@xyratex.com)
-Ondřej Nový (ondrej.novy@firma.seznam.cz)
+Clay Gerrard (clay.gerrard@gmail.com)
Davanum Srinivas (davanum@gmail.com)
-Victor Stinner (vstinner@redhat.com)
+Eric Lambert (eric_lambert@xyratex.com)
+Jim Cheung (jim.cheung@phazr.io)
+John Dickinson (me@not.mn)
+Kota Tsuyuzaki (bloodeagle40234@gmail.com)
Mark Storer (Mark.Storer@evault.com)
-Kota Tsuyuzaki (bloodeagle40123@gmail.com)
+Ondřej Nový (ondrej.novy@firma.seznam.cz)
Pete Zaitcev (zaitcev@kotori.zaitcev.us)
+Thiago da Silva (thiago@redhat.com)
+Timur Alperovich (timuralp@swiftstack.com)
+Tim Burke (tim.burke@gmail.com)
+Victor Stinner (vstinner@redhat.com)
Yuan Zhou (yuan.zhou@intel.com)
+
diff --git a/ChangeLog b/ChangeLog
index 0336d5d..3ad5e89 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,7 +1,16 @@
+New in 1.5.0
+------------
+
+ * Added support for Phazr.IO libphazr library.
+ * Fixed error handling that caused segfaults.
+ * Use version number exposed by liberasurecode.
+ * various other minor bugs fixes and improvements.
+
+
New in 1.4.0
------------
- * Add support for ISA-L Cauchy
+ * Added support for ISA-L Cauchy
* Fixed memory leak in get_metadata
* Added soft warning log line when using liberasurecode <1.3.1
diff --git a/doc/source/conf.py b/doc/source/conf.py
index 48214ef..8d51341 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -48,9 +48,9 @@ copyright = u'2016, Kevin Greenan, Tushar Gohad, Kota Tsuyuzaki'
# built documents.
#
# The short X.Y version.
-version = '1.4.0'
+version = '1.5.0'
# The full version, including alpha/beta/rc tags.
-release = '1.4.0'
+release = '1.5.0'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/setup.py b/setup.py
index 41d47ec..66e3470 100644
--- a/setup.py
+++ b/setup.py
@@ -159,7 +159,7 @@ class install(_install):
module = Extension('pyeclib_c',
define_macros=[('MAJOR VERSION', '1'),
- ('MINOR VERSION', '4')],
+ ('MINOR VERSION', '5')],
include_dirs=[default_python_incdir,
'src/c/pyeclib_c',
'/usr/include',
@@ -172,7 +172,7 @@ module = Extension('pyeclib_c',
sources=['src/c/pyeclib_c/pyeclib_c.c'])
setup(name='pyeclib',
- version='1.4.0',
+ version='1.5.0',
author='Kevin Greenan',
author_email='kmgreen2@gmail.com',
maintainer='Kevin Greenan and Tushar Gohad',