summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Burke <tim.burke@gmail.com>2019-02-13 08:42:30 -0800
committerTim Burke <tim.burke@gmail.com>2019-02-13 09:43:04 -0800
commit0e3afd3b946d8bf0fa8353c1ac18fed391cb20dc (patch)
tree780ea46e9a9e7444cdb9cde1088d90bb0d48db23
parent04092a3f201b5053bc13968364053b0cd843573d (diff)
downloadpyeclib-0e3afd3b946d8bf0fa8353c1ac18fed391cb20dc.tar.gz
Fix gate
Change-Id: I1c9bd3a4706a1d7235981f15cb6e1f4cc8d7ff55
-rw-r--r--README.rst2
-rw-r--r--pyeclib/enum.py2
-rw-r--r--pyeclib/utils.py4
-rw-r--r--setup.py9
-rw-r--r--test/test_pyeclib_api.py8
5 files changed, 13 insertions, 12 deletions
diff --git a/README.rst b/README.rst
index 67620da..e00ea65 100644
--- a/README.rst
+++ b/README.rst
@@ -19,7 +19,7 @@ reconstruction (think XOR-based LRC code).
-----
Installation
-===========
+============
Install pre-requisites:
diff --git a/pyeclib/enum.py b/pyeclib/enum.py
index f0b9aba..0e24fe9 100644
--- a/pyeclib/enum.py
+++ b/pyeclib/enum.py
@@ -134,7 +134,7 @@ class _EnumDict(dict):
"""
if pyver >= 3.0 and key == '__order__':
- return
+ return
if _is_sunder(key):
raise ValueError('_names_ are reserved for future Enum use')
elif _is_dunder(key):
diff --git a/pyeclib/utils.py b/pyeclib/utils.py
index 3b7e535..e3b04a7 100644
--- a/pyeclib/utils.py
+++ b/pyeclib/utils.py
@@ -61,8 +61,8 @@ def create_instance(import_str, *args, **kwargs):
Returns instance of class which imported by import path.
:param import_str: import path of class
- :param \*args: indexed arguments for new instance
- :param \*\*kwargs: keyword arguments for new instance
+ :param *args: indexed arguments for new instance
+ :param **kwargs: keyword arguments for new instance
:returns: instance of imported class which instantiated with
arguments *args and **kwargs
"""
diff --git a/setup.py b/setup.py
index 9a064f9..bd6c644 100644
--- a/setup.py
+++ b/setup.py
@@ -189,10 +189,11 @@ setup(name='pyeclib',
maintainer_email='kmgreen2@gmail.com, tusharsg@gmail.com',
url='http://git.openstack.org/cgit/openstack/pyeclib/',
bugtrack_url='https://bugs.launchpad.net/pyeclib',
- description='This library provides a simple Python interface for \
- implementing erasure codes. To obtain the best possible \
- performance, the underlying erasure code algorithms are \
- written in C.',
+ description=('This library provides a simple Python interface for '
+ 'implementing erasure codes. To obtain the best possible '
+ 'performance, the underlying erasure code algorithms are '
+ 'written in C.'),
+ long_description=open('README.rst', 'r').read(),
platforms='Linux',
license='BSD',
ext_modules=[module],
diff --git a/test/test_pyeclib_api.py b/test/test_pyeclib_api.py
index 4903f73..d53953a 100644
--- a/test/test_pyeclib_api.py
+++ b/test/test_pyeclib_api.py
@@ -159,10 +159,10 @@ class TestPyECLibDriver(unittest.TestCase):
available_ec_types = []
for _type in ALL_EC_TYPES:
try:
- if _type is 'shss':
+ if _type == 'shss':
_k = 10
_m = 4
- elif _type is 'libphazr':
+ elif _type == 'libphazr':
_k = 4
_m = 4
else:
@@ -183,9 +183,9 @@ class TestPyECLibDriver(unittest.TestCase):
print("Skipping test for %s backend" % _type)
continue
try:
- if _type is 'shss':
+ if _type == 'shss':
ECDriver(k=10, m=4, ec_type=_type)
- elif _type is 'libphazr':
+ elif _type == 'libphazr':
ECDriver(k=4, m=4, ec_type=_type)
else:
ECDriver(k=10, m=5, ec_type=_type)