summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Burke <tim.burke@gmail.com>2021-10-25 21:45:31 -0700
committerTim Burke <tim.burke@gmail.com>2021-10-25 21:45:31 -0700
commit61d1dd7d1e8e2c231a23258d9c5fcfcde7b88f29 (patch)
tree1cb2f897651a1106fff2111a5aecb9e5defd122a
parent218d5c59966dfde3dd71377a0169baa998245a37 (diff)
downloadpyeclib-61d1dd7d1e8e2c231a23258d9c5fcfcde7b88f29.tar.gz
Clean up install warning
Previously, running `python setup.py install` would include a UserWarning: Unknown distribution option: bugtrack_url Apparently, bugtrack_url isn't really a thing (anymore?), so include a custom project URL instead. Change-Id: I05dd64c63fe07e152b89a7f48ae7a4ab889e9b64
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 163d335..ff5b9fd 100644
--- a/setup.py
+++ b/setup.py
@@ -231,7 +231,9 @@ setup(name='pyeclib',
maintainer='Kevin Greenan and Tushar Gohad',
maintainer_email='kmgreen2@gmail.com, tusharsg@gmail.com',
url='https://opendev.org/openstack/pyeclib',
- bugtrack_url='https://bugs.launchpad.net/pyeclib',
+ project_urls={
+ 'Bug Tracker': 'https://bugs.launchpad.net/pyeclib',
+ },
description=('This library provides a simple Python interface for '
'implementing erasure codes. To obtain the best possible '
'performance, the underlying erasure code algorithms are '