summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Burke <tim.burke@gmail.com>2021-11-27 09:33:06 -0800
committerTim Burke <tim.burke@gmail.com>2021-11-29 11:16:56 -0800
commitb90881f866a97d443d6674f9ed2a059889d24a45 (patch)
tree909b02ecce679d5129b7709536fef51e3d107c8d
parent033fc066f386c4af854f8fad0adb2933fdbee662 (diff)
downloadpyeclib-b90881f866a97d443d6674f9ed2a059889d24a45.tar.gz
Docs build cleanup
Break doc requirements out to a separate file in the doc/ tree. Drop upper-bound on sphinx -- the gate job has been pulling from upper-constraints, anyway. Clean up a warning: WARNING: html_static_path entry '_static' does not exist Change-Id: I70010029060442fb31d96fce57e8f44a55424b7f
-rw-r--r--doc/requirements.txt1
-rw-r--r--doc/source/conf.py2
-rw-r--r--test-requirements.txt1
-rw-r--r--tox.ini2
4 files changed, 4 insertions, 2 deletions
diff --git a/doc/requirements.txt b/doc/requirements.txt
new file mode 100644
index 0000000..23a5062
--- /dev/null
+++ b/doc/requirements.txt
@@ -0,0 +1 @@
+sphinx>=1.1.2,!=1.2.0,!=1.3b1 # BSD
diff --git a/doc/source/conf.py b/doc/source/conf.py
index 1208b80..55b6f7d 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -120,7 +120,7 @@ html_theme = 'default'
# Add any paths that contain custom static files (such as style sheets) here,
# relative to this directory. They are copied after the builtin static files,
# so a file named "default.css" will overwrite the builtin "default.css".
-html_static_path = ['_static']
+#html_static_path = ['_static']
# If not '', a 'Last updated on:' timestamp is inserted at every page bottom,
# using the given strftime format.
diff --git a/test-requirements.txt b/test-requirements.txt
index 6d929e8..d0ffdef 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -5,4 +5,3 @@
coverage
nose
six>=1.9.0
-sphinx>=1.1.2,!=1.2.0,!=1.3b1,<1.3 # BSD
diff --git a/tox.ini b/tox.ini
index c8f003f..3ba6f24 100644
--- a/tox.ini
+++ b/tox.ini
@@ -26,4 +26,6 @@ commands=
commands = {posargs}
[testenv:docs]
+deps =
+ -r{toxinidir}/doc/requirements.txt
commands = python setup.py build_sphinx