summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTushar Gohad <tushar.gohad@intel.com>2015-11-23 03:26:07 +0000
committerTushar Gohad <tushar.gohad@intel.com>2015-11-23 03:34:25 +0000
commitf54a0e37ad5be285de40d5b1fa87e93c4304cc35 (patch)
tree58925c085e706d059724c5aaaf2474c9482e6894
parentefddaebedaad05859a2d3ce550e3f5f915bda181 (diff)
downloadpyeclib-f54a0e37ad5be285de40d5b1fa87e93c4304cc35.tar.gz
Add initial travis-ci config
-rw-r--r--.travis.yml12
1 files changed, 12 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..3707fb5
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,12 @@
+language: python
+python:
+ - "2.7"
+ - "3.4"
+script: python setup.py install && nosetests test/ && tox
+branches:
+ only:
+ - master
+before_install:
+ - echo "deb http://archive.ubuntu.com/ubuntu precise-backports main restricted universe multiverse" | sudo tee -a /etc/apt/sources.list
+ - sudo apt-get update
+ - sudo apt-get install -y liberasurecode-dev libffi-dev