summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--AUTHORS1
-rw-r--r--ChangeLog15
-rw-r--r--doc/source/conf.py4
-rw-r--r--setup.py9
4 files changed, 24 insertions, 5 deletions
diff --git a/AUTHORS b/AUTHORS
index d3beff0..c943c6c 100644
--- a/AUTHORS
+++ b/AUTHORS
@@ -8,6 +8,7 @@ Contributors
Timur Alperovich (timuralp@swiftstack.com)
Thiago da Silva (thiago@redhat.com)
Eric Lambert (eric_lambert@xyratex.com)
+Ondřej Nový (ondrej.novy@firma.seznam.cz)
Davanum Srinivas (davanum@gmail.com)
Victor Stinner (vstinner@redhat.com)
Mark Storer (Mark.Storer@evault.com)
diff --git a/ChangeLog b/ChangeLog
index 01dfbed..1cdd8a4 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,18 @@
+New in 1.3.0
+------------
+
+ * Updated liberasurecode dependency to 1.2.0.
+
+ * Fixed memory leak in get_segment_info (Launchpad bug #1604335).
+
+ * Properly return an error code if liberasurecode returns an
+ invalid fragment size.
+
+ * ECDriver() now requries "k" and "m" values to be passed in.
+
+ * Fix some requirements and installation instruction.
+
+
New in 1.2.1
------------
diff --git a/doc/source/conf.py b/doc/source/conf.py
index 1bbc468..65a8355 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -48,9 +48,9 @@ copyright = u'2016, Kevin Greenan, Tushar Gohad, Kota Tsuyuzaki'
# built documents.
#
# The short X.Y version.
-version = '1.2.1'
+version = '1.3.0'
# The full version, including alpha/beta/rc tags.
-release = '1.2.1'
+release = '1.3.0'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/setup.py b/setup.py
index 0b03855..4a1cb00 100644
--- a/setup.py
+++ b/setup.py
@@ -159,7 +159,7 @@ class install(_install):
module = Extension('pyeclib_c',
define_macros=[('MAJOR VERSION', '1'),
- ('MINOR VERSION', '2')],
+ ('MINOR VERSION', '3')],
include_dirs=[default_python_incdir,
'src/c/pyeclib_c',
'/usr/include',
@@ -172,12 +172,12 @@ module = Extension('pyeclib_c',
sources=['src/c/pyeclib_c/pyeclib_c.c'])
setup(name='PyECLib',
- version='1.2.1',
+ version='1.3.0',
author='Kevin Greenan',
author_email='kmgreen2@gmail.com',
maintainer='Kevin Greenan and Tushar Gohad',
maintainer_email='kmgreen2@gmail.com, tusharsg@gmail.com',
- url='https://bitbucket.org/kmgreen2/pyeclib',
+ url='http://git.openstack.org/cgit/openstack/pyeclib/',
description='This library provides a simple Python interface for \
implementing erasure codes. To obtain the best possible \
performance, the underlying erasure code algorithms are \
@@ -189,4 +189,7 @@ setup(name='PyECLib',
package_dir={'pyeclib': 'pyeclib'},
cmdclass={'build': build, 'install': install, 'clean': clean},
py_modules=['pyeclib.ec_iface', 'pyeclib.core'],
+ command_options={
+ 'build_sphinx': {
+ 'build_dir': ('setup.py', 'doc/build')}},
test_suite='test')