summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini10
1 files changed, 9 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 1adec18..e7ca727 100644
--- a/tox.ini
+++ b/tox.ini
@@ -18,7 +18,7 @@ install_command =
[testenv:pep8]
skip_install = True
deps=
- flake8
+ hacking
commands=
flake8 pyeclib/ setup.py test/
@@ -29,3 +29,11 @@ commands = {posargs}
deps =
-r{toxinidir}/doc/requirements.txt
commands = python setup.py build_sphinx
+
+[flake8]
+# H101: Use TODO(NAME)
+# H404: multi line docstring should start without a leading new line
+# H405: multi line docstring summary not separated with an empty line
+# W504: line break after binary operator
+ignore = H101,H404,H405,W504
+max-line-length = 88