summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteven Myint <git@stevenmyint.com>2018-01-28 07:45:56 -0800
committerGitHub <noreply@github.com>2018-01-28 07:45:56 -0800
commitb75144b4c9c75e16a1f75b912496c7dd44ef716c (patch)
treead509b903a821c50e2a5a19553305402e3ecd521
parent8e9d44cfce56694a8ef89f25d25a3557b8def1e4 (diff)
downloadpyflakes-b75144b4c9c75e16a1f75b912496c7dd44ef716c.tar.gz
Work around Travis CI error on Python "nightly" (#326)
* Work around Travis CI error on Python "nightly" * Keep installation clean as possible when testing Install the linting tools after testing is done. * Clean up
-rw-r--r--.travis.yml6
1 files changed, 2 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index 780b117..545d317 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -13,11 +13,9 @@ python:
- pypy3
- pypy3.3-5.2-alpha1
install:
- - pip install flake8==2.1.0 pep8==1.5.6
- - python setup.py install
+ - pip install --upgrade .
- pip list
- - if [ "$TRAVIS_PYTHON_VERSION" != "nightly" ]; then flake8 --version; fi
script:
- python setup.py test -q
- - if [ "$TRAVIS_PYTHON_VERSION" != "nightly" ]; then flake8 pyflakes setup.py; fi
+ - if [ "$TRAVIS_PYTHON_VERSION" != "nightly" ]; then pip install flake8==2.1.0 pep8==1.5.6 && flake8 --version && flake8 pyflakes setup.py; fi
sudo: false