summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo <hugovk@users.noreply.github.com>2018-03-25 23:31:00 +0300
committerSteven Myint <git@stevenmyint.com>2018-03-25 13:31:00 -0700
commitc2742b69e4801e3fe9d15862eb720a3a1e585d6e (patch)
tree797af28f6e89134129c783e418802bcdb7d760b3
parenta13dbe6652f2635b1a7e094a8eb8d27aec3f6c3f (diff)
downloadpyflakes-c2742b69e4801e3fe9d15862eb720a3a1e585d6e.tar.gz
Update versions (#303)
* Python 3.7 is supported (#273) * Update classifiers
-rw-r--r--README.rst4
-rwxr-xr-xsetup.py1
2 files changed, 3 insertions, 2 deletions
diff --git a/README.rst b/README.rst
index 6699b4c..ae9bfd7 100644
--- a/README.rst
+++ b/README.rst
@@ -9,7 +9,7 @@ parsing the source file, not importing it, so it is safe to use on
modules with side effects. It's also much faster.
It is `available on PyPI <https://pypi.python.org/pypi/pyflakes>`_
-and it supports all active versions of Python: 2.7 and 3.4 to 3.6.
+and it supports all active versions of Python: 2.7 and 3.4 to 3.7.
@@ -32,7 +32,7 @@ Useful tips:
* If you require more options and more flexibility, you could give a
look to Flake8_ too.
-
+
Design Principles
-----------------
diff --git a/setup.py b/setup.py
index 6567b53..5e2088e 100755
--- a/setup.py
+++ b/setup.py
@@ -57,6 +57,7 @@ setup(
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"Topic :: Software Development",