summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo van Kemenade <hugovk@users.noreply.github.com>2021-12-24 23:39:26 +0200
committerGitHub <noreply@github.com>2021-12-24 16:39:26 -0500
commitdbb18432165bdc567e015511b3f3284f0f14cf05 (patch)
tree13b761f02284adc4213624b7e77e47e3a255e908
parent140817fbc48498ab8e72cbc82d57914f1606b457 (diff)
downloadpyflakes-dbb18432165bdc567e015511b3f3284f0f14cf05.tar.gz
Drop support for EOL Python 2.7 and 3.4-3.5 (#660)master
* Add support for Python 3.10 * Drop support for EOL Python 2.7 and 3.4-3.5
-rw-r--r--.github/workflows/test.yml10
-rw-r--r--README.rst2
-rwxr-xr-xsetup.py9
-rw-r--r--tox.ini2
4 files changed, 10 insertions, 13 deletions
diff --git a/.github/workflows/test.yml b/.github/workflows/test.yml
index 8c078ae..fd21c11 100644
--- a/.github/workflows/test.yml
+++ b/.github/workflows/test.yml
@@ -8,14 +8,12 @@ jobs:
strategy:
fail-fast: false
matrix:
- python-version: ["2.7", "3.5", "3.6", "3.7", "3.8", "3.9", "3.10-dev", "pypy2", "pypy3"]
+ python-version: ["3.6", "3.7", "3.8", "3.9", "3.10", "pypy3"]
os: [ubuntu-latest]
- # Include py2 + minimum py3 + maximum py3 + pypy + pypy3 on Windows
+ # Include minimum py3 + maximum py3 + pypy3 on Windows
include:
- - { os: "windows-latest" , python-version: "2.7" }
- - { os: "windows-latest" , python-version: "3.5" }
- - { os: "windows-latest" , python-version: "3.9" }
- - { os: "windows-latest" , python-version: "pypy2" }
+ - { os: "windows-latest" , python-version: "3.6" }
+ - { os: "windows-latest" , python-version: "3.10" }
- { os: "windows-latest" , python-version: "pypy3" }
steps:
diff --git a/README.rst b/README.rst
index 47ea7ed..d651ba9 100644
--- a/README.rst
+++ b/README.rst
@@ -9,7 +9,7 @@ parsing the source file, not importing it, so it is safe to use on
modules with side effects. It's also much faster.
It is `available on PyPI <https://pypi.org/project/pyflakes/>`_
-and it supports all active versions of Python: 2.7 and 3.4 to 3.8.
+and it supports all active versions of Python: 3.6+.
diff --git a/setup.py b/setup.py
index 972718f..673a76d 100755
--- a/setup.py
+++ b/setup.py
@@ -42,21 +42,20 @@ setup(
author_email="code-quality@python.org",
url="https://github.com/PyCQA/pyflakes",
packages=["pyflakes", "pyflakes.scripts", "pyflakes.test"],
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
+ python_requires='>=3.6',
classifiers=[
"Development Status :: 6 - Mature",
"Environment :: Console",
"Intended Audience :: Developers",
"License :: OSI Approved :: MIT License",
"Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.4",
- "Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3 :: Only",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"Topic :: Software Development",
diff --git a/tox.ini b/tox.ini
index 0396f02..65e8361 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,7 @@
[tox]
skip_missing_interpreters = True
envlist =
- py27,py35,py36,py37,py38,py39,py310,pypy,pypy3
+ py36,py37,py38,py39,py310,pypy3
[testenv]
deps = flake8==3.6.0