diff options
author | David Pursehouse <david.pursehouse@sonymobile.com> | 2012-07-31 15:18:31 +0900 |
---|---|---|
committer | David Pursehouse <david.pursehouse@sonymobile.com> | 2012-07-31 15:18:31 +0900 |
commit | 37b8b76c49b3f0a5f8a26434f9653b0d3327c7a2 (patch) | |
tree | b81d44e6eab64f11cf4d65284b3f5f3e3829e418 | |
parent | 65106ac065be9239fdaa0f9da7933564156f6d1e (diff) | |
download | pygerrit-37b8b76c49b3f0a5f8a26434f9653b0d3327c7a2.tar.gz |
Add setup.py
Add setup.py which is needed to install pygerrit as a python package.
Also added build-generated files to .gitignore.
Change-Id: I0883debc370d679d0d872cdaf136399c0e0bcf43
-rw-r--r-- | .gitignore | 3 | ||||
-rwxr-xr-x | setup.py | 16 |
2 files changed, 19 insertions, 0 deletions
@@ -2,3 +2,6 @@ .project .pydevproject .settings +build/ +dist/ +pygerrit.egg-info/ diff --git a/setup.py b/setup.py new file mode 100755 index 0000000..1237f97 --- /dev/null +++ b/setup.py @@ -0,0 +1,16 @@ +""" Client library for interacting with Gerrit. """ + +from setuptools import setup + +setup( + name="pygerrit", + description="Client library for interacting with Gerrit", + version="0.0.2", + author="David Pursehouse", + author_email="david.pursehouse@sonymobile.com", + maintainer="David Pursehouse", + maintainer_email="david.pursehouse@sonymobile.com", + url="http://sonymobile.com", + packages=['pygerrit'], + keywords='gerrit, json', +) |