summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Pursehouse <david.pursehouse@sonymobile.com>2012-09-19 18:24:19 +0900
committerDavid Pursehouse <david.pursehouse@sonymobile.com>2012-09-20 13:54:22 +0900
commitfa27eb4280e2218caf50b9e613fa46335cdc2a13 (patch)
tree34aaba7f0bc82ab473905f3850cd21d674c55c59
parent1d741888256154832cfc74e055a9ad6b37eaaddc (diff)
downloadpygerrit-fa27eb4280e2218caf50b9e613fa46335cdc2a13.tar.gz
Add license information
Change-Id: I25ce3fafe7a51d0221f66fe30b2fb7cc8115c4aa
-rw-r--r--README.md22
-rwxr-xr-xexample.py26
-rw-r--r--pygerrit/__init__.py26
-rw-r--r--pygerrit/client.py26
-rw-r--r--pygerrit/error.py27
-rw-r--r--pygerrit/events.py27
-rw-r--r--pygerrit/models.py27
-rw-r--r--pygerrit/ssh.py26
-rw-r--r--pygerrit/stream.py24
-rwxr-xr-xsetup.py27
-rwxr-xr-xunittests.py26
11 files changed, 274 insertions, 10 deletions
diff --git a/README.md b/README.md
new file mode 100644
index 0000000..2258bd7
--- /dev/null
+++ b/README.md
@@ -0,0 +1,22 @@
+The MIT License
+
+Copyright 2011 Sony Ericsson Mobile Communications. All rights reserved.
+Copyright 2012 Sony Mobile Communications. All rights reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/example.py b/example.py
index 95c7c21..954174d 100755
--- a/example.py
+++ b/example.py
@@ -1,6 +1,30 @@
#!/usr/bin/env python
-""" Example of using the Gerrit client class. """
+""" Example of using the Gerrit client class.
+
+The MIT License
+
+Copyright 2012 Sony Mobile Communications. All rights reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
+
+"""
import logging
import optparse
diff --git a/pygerrit/__init__.py b/pygerrit/__init__.py
index 100380b..d9574b6 100644
--- a/pygerrit/__init__.py
+++ b/pygerrit/__init__.py
@@ -1,4 +1,28 @@
-""" Module to interface with Gerrit. """
+""" Module to interface with Gerrit.
+
+The MIT License
+
+Copyright 2012 Sony Mobile Communications. All rights reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
+
+"""
def from_json(json_data, key):
diff --git a/pygerrit/client.py b/pygerrit/client.py
index 5073e93..1d5fa44 100644
--- a/pygerrit/client.py
+++ b/pygerrit/client.py
@@ -1,4 +1,28 @@
-""" Gerrit client interface. """
+""" Gerrit client interface.
+
+The MIT License
+
+Copyright 2012 Sony Mobile Communications. All rights reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
+
+"""
from Queue import Queue, Empty, Full
diff --git a/pygerrit/error.py b/pygerrit/error.py
index d52eb6c..15fe681 100644
--- a/pygerrit/error.py
+++ b/pygerrit/error.py
@@ -1,4 +1,29 @@
-""" Error classes. """
+""" Error classes.
+
+The MIT License
+
+Copyright 2011 Sony Ericsson Mobile Communications. All rights reserved.
+Copyright 2012 Sony Mobile Communications. All rights reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
+
+"""
class GerritError(Exception):
diff --git a/pygerrit/events.py b/pygerrit/events.py
index 72a92ed..ff54096 100644
--- a/pygerrit/events.py
+++ b/pygerrit/events.py
@@ -1,4 +1,29 @@
-""" Gerrit event classes. """
+""" Gerrit event classes.
+
+The MIT License
+
+Copyright 2011 Sony Ericsson Mobile Communications. All rights reserved.
+Copyright 2012 Sony Mobile Communications. All rights reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
+
+"""
from pygerrit.error import GerritError
from pygerrit.models import Account, Approval, Change, Patchset, RefUpdate
diff --git a/pygerrit/models.py b/pygerrit/models.py
index f0d4d7f..4260566 100644
--- a/pygerrit/models.py
+++ b/pygerrit/models.py
@@ -1,4 +1,29 @@
-""" Models for Gerrit JSON data. """
+""" Models for Gerrit JSON data.
+
+The MIT License
+
+Copyright 2011 Sony Ericsson Mobile Communications. All rights reserved.
+Copyright 2012 Sony Mobile Communications. All rights reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
+
+"""
from pygerrit import from_json
diff --git a/pygerrit/ssh.py b/pygerrit/ssh.py
index f6310a0..a675b47 100644
--- a/pygerrit/ssh.py
+++ b/pygerrit/ssh.py
@@ -1,4 +1,28 @@
-""" Gerrit SSH Client. """
+""" Gerrit SSH Client.
+
+The MIT License
+
+Copyright 2012 Sony Mobile Communications. All rights reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
+
+"""
from os.path import abspath, expanduser, isfile
diff --git a/pygerrit/stream.py b/pygerrit/stream.py
index c786ad0..d324422 100644
--- a/pygerrit/stream.py
+++ b/pygerrit/stream.py
@@ -2,6 +2,28 @@
Class to listen to the Gerrit event stream and dispatch events.
+The MIT License
+
+Copyright 2012 Sony Mobile Communications. All rights reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
+
"""
import json
@@ -16,7 +38,7 @@ from pygerrit.events import GerritEvent, GerritEventFactory
@GerritEventFactory.register("gerrit-stream-error")
class GerritStreamErrorEvent(GerritEvent):
- """ Represents an error when handling the gerrit event stream """
+ """ Represents an error when handling the gerrit event stream. """
def __init__(self, json_data):
super(GerritStreamErrorEvent, self).__init__()
diff --git a/setup.py b/setup.py
index 3752f1b..1723b37 100755
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,28 @@
-""" Client library for interacting with Gerrit. """
+""" Client library for interacting with Gerrit.
+
+The MIT License
+
+Copyright 2012 Sony Mobile Communications. All rights reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
+
+"""
from setuptools import setup
@@ -6,6 +30,7 @@ setup(
name="pygerrit",
description="Client library for interacting with Gerrit",
version="0.0.3",
+ license="The MIT License",
author="David Pursehouse",
author_email="david.pursehouse@sonymobile.com",
maintainer="David Pursehouse",
diff --git a/unittests.py b/unittests.py
index 6665494..ec96942 100755
--- a/unittests.py
+++ b/unittests.py
@@ -1,7 +1,31 @@
#!/usr/bin/env python
# -*- coding: utf-8 -*-
-""" Unit tests for the Gerrit event stream handler and event objects. """
+""" Unit tests for the Gerrit event stream handler and event objects.
+
+The MIT License
+
+Copyright 2012 Sony Mobile Communications. All rights reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
+
+"""
import json
import os