summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Pursehouse <david.pursehouse@sonymobile.com>2014-10-22 14:20:32 +0900
committerDavid Pursehouse <david.pursehouse@sonymobile.com>2014-10-22 14:25:52 +0900
commitfaa1b0ad01a3b46c45b7aa3e5222b8fb8943090a (patch)
treee9eec14252fe3cef5b9cb48fa76a17d9191ec10b
parentbe1e7ac58ef253f8bf06d61eacf65f52fdcc55c3 (diff)
downloadpygerrit-faa1b0ad01a3b46c45b7aa3e5222b8fb8943090a.tar.gz
Fix documentation build
Current implementation only works properly for the latest tag. Change it so we can build documentation at any revision. Change-Id: I8cc0e3ef449d8f861411ca86ba676a0f9c89009f
-rw-r--r--Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 9d029f3..425501f 100644
--- a/Makefile
+++ b/Makefile
@@ -21,7 +21,7 @@
# THE SOFTWARE.
PWD := $(shell pwd)
-TAG := $(shell git tag -l --contains HEAD)
+VERSION := $(shell git describe)
VIRTUALENV := $(shell which virtualenv)
ifeq ($(wildcard $(VIRTUALENV)),)
@@ -51,7 +51,7 @@ sdist: valid-virtualenv test
ddist: sdist docs
bash -c "\
cd docs/_build/html && \
- zip -r $(PWD)/dist/pygerrit-$(TAG)-api-documentation.zip . && \
+ zip -r $(PWD)/dist/pygerrit-$(VERSION)-api-documentation.zip . && \
cd $(PWD)"
valid-virtualenv:
@@ -71,8 +71,8 @@ sphinx: docenvsetup
bash -c "\
source ./pygerritenv/bin/activate && \
sphinx-apidoc \
- -V \"$(TAG)\" \
- -R \"$(TAG)\" \
+ -V \"$(VERSION)\" \
+ -R \"$(VERSION)\" \
-H \"Pygerrit\" \
-A \"Sony Mobile Communications\" \
--full \