summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDavid Pursehouse <david.pursehouse@sonymobile.com>2013-08-07 11:03:54 +0900
committerDavid Pursehouse <david.pursehouse@sonymobile.com>2013-08-07 15:22:12 +0900
commit4dd516877f113ba05c98d5b38afb16af702a5bd4 (patch)
treed4dd9e029e3119a4b0eea8cdb3afd1c1a824c854 /Makefile
parenta3378568b9415cdba2690c756af0011fc5eb0744 (diff)
downloadpygerrit-4dd516877f113ba05c98d5b38afb16af702a5bd4.tar.gz
Add a make target to build the API documentation zip archive
The `ddist` target packages the generated API documentation into a zip archive file suitable for uploading to PyPI. Change-Id: Ib94f445d03bdb45e817355ef1ad0d8119e10a0d9
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 5a640f8..65ce661 100644
--- a/Makefile
+++ b/Makefile
@@ -35,6 +35,12 @@ sdist: test valid-env
source ./pygerritenv/bin/activate && \
python setup.py sdist"
+ddist: sdist docs
+ bash -c "\
+ cd docs/_build/html && \
+ zip -r $(PWD)/dist/pygerrit-$(TAG)-api-documentation.zip . && \
+ cd $(PWD)"
+
valid-env: valid-version valid-git-status
valid-version: valid-tag