summaryrefslogtreecommitdiff
path: root/pygerrit/__init__.py
diff options
context:
space:
mode:
authorDavid Pursehouse <david.pursehouse@sonymobile.com>2013-08-04 14:33:19 +0900
committerDavid Pursehouse <david.pursehouse@sonymobile.com>2013-08-05 19:18:11 +0900
commitbb44bf7c42a1797fc9a6d22c5be7ba3eff4b8744 (patch)
tree42d717ecab809d50aedee38f6b460ce431dce1aa /pygerrit/__init__.py
parentee0a7001bf42c4fee00b480865bede265bffaf22 (diff)
downloadpygerrit-bb44bf7c42a1797fc9a6d22c5be7ba3eff4b8744.tar.gz
Don't hard code version in setup.py
We're currently only using the version number in the setup script, but in future we might need it in other places too. Define the version number in the module itself and import it in setup. Change-Id: Idbf246d3a9777f6de710cb01fa05f8fbf031d192
Diffstat (limited to 'pygerrit/__init__.py')
-rw-r--r--pygerrit/__init__.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/pygerrit/__init__.py b/pygerrit/__init__.py
index 5fa98be..b268fb3 100644
--- a/pygerrit/__init__.py
+++ b/pygerrit/__init__.py
@@ -24,6 +24,9 @@ THE SOFTWARE.
"""
+__numversion__ = (0, 0, 7)
+__version__ = '.'.join([str(num) for num in __numversion__])
+
def from_json(json_data, key):
""" Helper method to extract values from JSON data.