summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Pursehouse <david.pursehouse@sonymobile.com>2012-08-24 13:57:25 +0900
committerDavid Pursehouse <david.pursehouse@sonymobile.com>2012-09-03 17:53:08 +0900
commit424415197211d32eaeb84630542bcab3cc6521b0 (patch)
tree7224108a1d43047c8e4304a184c6eb52bbb13698 /setup.py
parent26bc11340590b0b863527fa12da03cea528feb46 (diff)
downloadpygerrit-424415197211d32eaeb84630542bcab3cc6521b0.tar.gz
Add GerritSSHClient
Add initial version of GerritSSHClient, which is a wrapper for paramiko's SSHClient. The class derives from SSHClient and configures the ssh connection from the user's ssh config file. Change-Id: I54a193e41356de272c95c5288ed2c9e50a776cdf
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 1237f97..36f0deb 100755
--- a/setup.py
+++ b/setup.py
@@ -13,4 +13,5 @@ setup(
url="http://sonymobile.com",
packages=['pygerrit'],
keywords='gerrit, json',
+ install_requires=['paramiko'],
)