summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Pursehouse <david.pursehouse@sonymobile.com>2014-04-28 16:34:25 +0900
committerDavid Pursehouse <david.pursehouse@sonymobile.com>2014-05-02 10:21:17 +0900
commit8e9ae8c819e9927b2a41678ec186eac2cf035ab6 (patch)
tree919e226c9be3df0166bfebeff6e60aaf2fa85020 /setup.py
parent0cd7518c21140d480e06a1d6086b6fe71e6d7533 (diff)
downloadpygerrit-8e9ae8c819e9927b2a41678ec186eac2cf035ab6.tar.gz
Migrate setup to pbr
pbr provides better version handling, and automates the release notes and list of authors. This means we have to spend less time manually updating things. Change-Id: Ie79d706ec7a177f437b6bb0e38a9bded8bc4bb9e
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py36
1 files changed, 5 insertions, 31 deletions
diff --git a/setup.py b/setup.py
index ea6b59f..97d4d57 100755
--- a/setup.py
+++ b/setup.py
@@ -25,40 +25,14 @@
""" Client library for interacting with Gerrit. """
-from setuptools import setup, find_packages
-
-from pygerrit import __version__
-
-REQUIRES = ['requests==2.0.1']
+import setuptools
def _main():
- setup(
- name="pygerrit",
- description="Client library for interacting with Gerrit",
- long_description=open('README.rst').read(),
- version=__version__,
- license=open('LICENSE').read(),
- author="David Pursehouse",
- author_email="david.pursehouse@sonymobile.com",
- maintainer="David Pursehouse",
- maintainer_email="david.pursehouse@sonymobile.com",
- url="https://github.com/sonyxperiadev/pygerrit",
- packages=find_packages(),
- keywords='gerrit, json, rest, http',
- install_requires=REQUIRES,
- classifiers=(
- 'Development Status :: 3 - Alpha',
- 'Environment :: Console',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: MIT License',
- 'Natural Language :: English',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 2.7',
- ),
- )
-
+ setuptools.setup(
+ packages=setuptools.find_packages(),
+ setup_requires=['pbr'],
+ pbr=True)
if __name__ == "__main__":
_main()