summaryrefslogtreecommitdiff
path: root/.dockerignore
diff options
context:
space:
mode:
authoramitkummer <49096391+amitkummer@users.noreply.github.com>2022-05-21 18:56:08 +0300
committerGitHub <noreply@github.com>2022-05-21 17:56:08 +0200
commitcbcbffea1b1f8edf4b824edadbb181f5143ce9ab (patch)
tree10043832a312f0312368620e970cf720dde5a2d5 /.dockerignore
parent78e2a410033e53481bc33bf7b192145c63dc6623 (diff)
downloadpygments-git-cbcbffea1b1f8edf4b824edadbb181f5143ce9ab.tar.gz
Overhaul demo and support running it locally (#2141)
* Add Make target for building Pyodide with currently checked out Pygments Add a target to the documentation's Makefile to make Pyodide with Pygments from the current checkout. Additionally, use this target when building the documentation with the demo page. The new target works by building Pyodide on a Docker container, and then exporting the build artifacts back to the host. The Dockerfile used by the new target is based on the Dockerfile which was used for building Pyodide on the CI: https://github.com/pygments/pyodide-artifacts/blob/master/container/Dockerfile The main difference between the two is that the new Dockerfile uses the newest Pyodide base image, which is built by a repository which is actively maintained (the Iodide project is no longer maintained). The purpose of this change is to allow running the demo locally, which was not possible previously, as Pyodide was only built by the CI when deploying to Github Pages. * Add instructions on how to run the demo locally to the README * Update demo to work with Pyodide v0.20 Remove usage of Pyodide functionality which was deprecated in Pyodide v0.17: - Loading Pyodide using `languagePluginURL` and `languagePluginLoader`. - Access to globals via `pyodide.globals.x` has changed to `pyodide.globals.get("x")`. Source: https://pyodide.org/en/stable/project/release-notes/v0.17.0.html?highlight=languageplugin#api-changes * Fix #2137 * Fix use of `styles` variable before it's defined The `styles` variable was being used before it's value was set (which is done when Pyodide finishes loading). * Remove GitHub action for building Pyodide This action is obsolete, as building Pyodide is now done using `make pyodide`. * Upgrade Pages deployment action version * Add to .dockerignore all files in .gitignore * Change `pyodide` target to be a phony target
Diffstat (limited to '.dockerignore')
-rw-r--r--.dockerignore16
1 files changed, 16 insertions, 0 deletions
diff --git a/.dockerignore b/.dockerignore
new file mode 100644
index 00000000..e08d9e1d
--- /dev/null
+++ b/.dockerignore
@@ -0,0 +1,16 @@
+doc
+tests
+Pygments.egg-info
+TAGS
+build
+dist
+htmlcov
+venv
+**/__pycache__
+.*
+*.rst
+*.egg
+*.pyo
+.*.sw[op]
+
+!/doc/pyodide/meta.yaml